summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrien Prost-Boucle2019-03-05 20:43:11 +0100
committerAdrien Prost-Boucle2019-03-05 20:43:11 +0100
commit7960e30c842fade58e7c082f6bacc8d500115f71 (patch)
tree839d0282f883850ae85f2585375e346f12ca4146
parent0d1af82f470e671a31b03e1c3fe748f9a7a64766 (diff)
downloadaur-7960e30c842fade58e7c082f6bacc8d500115f71.tar.gz
Update for new GHDL git repository
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 19 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6917e06068c1..eeafa079e8f8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Dec 19 12:04:15 UTC 2017
+# Tue Mar 5 19:42:28 UTC 2019
pkgbase = ghdl-gcc-git
pkgdesc = VHDL simulator - GCC flavour
- pkgver = 0.36dev.git20171218
+ pkgver = 0.37dev.git20190303
pkgrel = 1
url = https://github.com/tgingold/ghdl
install = ghdl.install
@@ -16,12 +16,12 @@ pkgbase = ghdl-gcc-git
conflicts = ghdl-mcode-git
options = !emptydirs
options = staticlibs
- source = ghdl::git://github.com/tgingold/ghdl.git
- source = ftp://ftp.gnu.org/gnu/gcc/gcc-7.2.0/gcc-7.2.0.tar.xz
- source = http://isl.gforge.inria.fr/isl-0.18.tar.bz2
+ source = ghdl::git://github.com/ghdl/ghdl.git
+ source = ftp://ftp.gnu.org/gnu/gcc/gcc-8.3.0/gcc-8.3.0.tar.xz
+ source = http://isl.gforge.inria.fr/isl-0.20.tar.bz2
md5sums = SKIP
- md5sums = ff370482573133a7fcdd96cd2f552292
- md5sums = 11436d6b205e516635b666090b94ab32
+ md5sums = 65b210b4bfe7e060051f799e0f994896
+ md5sums = cb396f31b24aeeac49840b519741b0e1
pkgname = ghdl-gcc-git
diff --git a/PKGBUILD b/PKGBUILD
index 8846bd15c980..d8590d78dd41 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# https://aur.archlinux.org/packages/ghdl/
pkgname=ghdl-gcc-git
-pkgver=0.36dev.git20171218
+pkgver=0.37dev.git20190303
pkgrel=1
arch=('any')
pkgdesc='VHDL simulator - GCC flavour'
@@ -16,25 +16,25 @@ makedepends=('gcc-ada' 'git')
install=ghdl.install
options=(!emptydirs staticlibs)
-_gccver=7.2.0
-_islver=0.18
+_gccver=8.3.0
+_islver=0.20
source=(
- "ghdl::git://github.com/tgingold/ghdl.git"
+ "ghdl::git://github.com/ghdl/ghdl.git"
"ftp://ftp.gnu.org/gnu/gcc/gcc-${_gccver}/gcc-${_gccver}.tar.xz"
"http://isl.gforge.inria.fr/isl-${_islver}.tar.bz2"
)
md5sums=(
'SKIP'
- 'ff370482573133a7fcdd96cd2f552292'
- '11436d6b205e516635b666090b94ab32'
+ '65b210b4bfe7e060051f799e0f994896'
+ 'cb396f31b24aeeac49840b519741b0e1'
)
pkgver() {
cd "${srcdir}/ghdl"
- # GHDL version (extracted from version.in)
- _distver=`sed -n -e 's/.*Ghdl_Ver .*"\(.*\)".*/\1/p' src/version.in | tr -d '-'`
+ # GHDL version (extracted from version.ads)
+ _distver=`sed -n -e 's/.*Ghdl_Ver .*"\(.*\)".*/\1/p' version.ads | tr -d '-'`
# Date of the last git commit
_gitver=`git log -n 1 --date=short | sed -n -e 's/.*Date:\s*\([0-9-]*\).*/\1/p' | tr -d -`
@@ -58,8 +58,10 @@ prepare() {
# Do not run fixincludes - FIXME Why?
sed -i 's@\./fixinc\.sh@-c true@' gcc/Makefile.in
- # Arch Linux installs x86_64 libraries in /lib
- [[ $CARCH == "x86_64" ]] && sed -i '/m64=/s/lib64/lib/' gcc/config/i386/t-linux64
+ # Arch Linux installs libraries in /lib
+ # FIXME How to fix this for all architectures ?
+ sed -i '/m64=/s/lib64/lib/' gcc/config/i386/t-linux64
+ sed -i '/lp64=/s/lib64/lib/' gcc/config/aarch64/t-aarch64-linux
# hack! - some configure tests for header files using "$CPP $CPPFLAGS"
sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" {libiberty,gcc}/configure
@@ -89,7 +91,6 @@ build() {
--infodir=/usr/share/info \
--enable-shared \
--enable-threads=posix \
- --enable-libmpx \
--with-system-zlib \
--with-isl \
--enable-__cxa_atexit \