summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrien Prost-Boucle2015-12-02 00:33:33 +0100
committerAdrien Prost-Boucle2015-12-02 00:33:33 +0100
commitba7e44b284db67822304f15013cfc4e186319e55 (patch)
tree1756211af49a36facb945ec04ec8fc3745cdb327
downloadaur-ba7e44b284db67822304f15013cfc4e186319e55.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD55
2 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..32d53e08e3ea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = ghdl-mcode-git
+ pkgdesc = VHDL simulator - mcode version
+ pkgver = 0.34dev.git20151130
+ pkgrel = 1
+ url = http://sourceforge.net/projects/ghdl-updates/
+ arch = i686
+ arch = x86_64
+ license = GPLv2
+ makedepends = gcc-ada-multilib
+ makedepends = git
+ depends = lib32-glibc
+ depends = lib32-zlib
+ provides = ghdl
+ conflicts = ghdl
+ conflicts = ghdl-hg
+ conflicts = ghdl-llvm-hg
+ conflicts = ghdl-mcode-hg
+ conflicts = ghdl-gcc-git
+ conflicts = ghdl-llvm-git
+ source = ghdl::git://github.com/tgingold/ghdl.git
+ md5sums = SKIP
+
+pkgname = ghdl-mcode-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c02c008873bf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Adrien Prost-Boucle <adrien.prost-boucle@laposte.net>
+
+pkgname=ghdl-mcode-git
+pkgver=0.34dev.git20151130
+pkgrel=1
+arch=('i686' 'x86_64')
+pkgdesc='VHDL simulator - mcode version'
+url='http://sourceforge.net/projects/ghdl-updates/'
+license=('GPLv2')
+
+provides=('ghdl')
+conflicts=('ghdl' 'ghdl-hg' 'ghdl-llvm-hg' 'ghdl-mcode-hg' 'ghdl-gcc-git' 'ghdl-llvm-git')
+makedepends=('gcc-ada-multilib' 'git')
+depends=('lib32-glibc' 'lib32-zlib')
+
+source=(
+ "ghdl::git://github.com/tgingold/ghdl.git"
+)
+md5sums=(
+ 'SKIP'
+)
+
+pkgver() {
+ cd "${srcdir}/ghdl"
+
+ # GHDL version (extracted from version.ads)
+ _distver=`sed -n -e 's/.*GHDL \([0-9.a-z]*\) (.*/\1/p' src/version.ads`
+ # Date of the last git commit
+ _gitver=`git log -n 1 --date=short | sed -n -e 's/.*Date:\s*\([0-9-]*\).*/\1/p' | tr -d -`
+
+ echo $_distver.git$_gitver;
+}
+
+build() {
+ cd "${srcdir}/ghdl"
+
+ ./configure --prefix=/usr/
+
+ # Set flags for 32-bits compatibility
+ if [[ `uname -m` -eq "x86_64" ]]
+ then
+ sed -i 's@CC=gcc@CC=gcc -m32@' Makefile
+ sed -i 's@GNATMAKE=gnatmake@GNATMAKE=gnatmake -m32@' Makefile
+ fi
+
+ make
+
+}
+
+package() {
+ cd "${srcdir}/ghdl"
+
+ make DESTDIR="${pkgdir}" install
+
+}