summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXiretza2020-04-01 14:46:34 +0200
committerXiretza2020-04-01 14:46:34 +0200
commitfd75ff9632fad759101db7aac2149454ad0f34c1 (patch)
treedced7007ed87fb174f13209c30feffc98970080a
parent90e3f937ff53967894cbcc24d9d8423ba512ef90 (diff)
downloadaur-fd75ff9632fad759101db7aac2149454ad0f34c1.tar.gz
Rename package to ghdl-yosys-plugin-git
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD36
2 files changed, 30 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 520e4c4463e3..23da7ff752b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,21 @@
-pkgbase = ghdlsynth-beta-git
- pkgdesc = VHDL synthesis (based on ghdl)
- pkgver = r117.c975230
+pkgbase = ghdl-yosys-plugin-git
+ pkgdesc = VHDL synthesis (based on ghdl and yosys)
+ pkgver = r123.ef286d8
pkgrel = 1
- url = https://github.com/tgingold/ghdlsynth-beta
+ url = https://github.com/ghdl/ghdl-yosys-plugin
arch = x86_64
license = GPL3
makedepends = git
- makedepends = yosys
makedepends = clang
depends = ghdl-git
- depends = gcc-libs
- provides = ghdlsynth-beta
- provides = ghdlsynth
+ depends = yosys
+ provides = ghdl-yosys-plugin
+ conflicts = ghdl-yosys-plugin
conflicts = ghdlsynth-beta
- conflicts = ghdlsynth
+ replaces = ghdlsynth-beta-git
options = !debug
- source = ghdlsynth::git://github.com/tgingold/ghdlsynth-beta.git
+ source = git://github.com/ghdl/ghdl-yosys-plugin.git
sha256sums = SKIP
-pkgname = ghdlsynth-beta-git
+pkgname = ghdl-yosys-plugin-git
diff --git a/PKGBUILD b/PKGBUILD
index 7c6bd2d086b8..760380fdeca0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,47 @@
# Maintainer: xiretza <xiretza+aur@xiretza.xyz>
-pkgname=ghdlsynth-beta-git
-pkgver=r117.c975230
+pkgname=ghdl-yosys-plugin-git
+pkgver=r123.ef286d8
pkgrel=1
arch=('x86_64')
-pkgdesc='VHDL synthesis (based on ghdl)'
-url='https://github.com/tgingold/ghdlsynth-beta'
+pkgdesc='VHDL synthesis (based on ghdl and yosys)'
+url='https://github.com/ghdl/ghdl-yosys-plugin'
license=('GPL3')
-provides=('ghdlsynth-beta' 'ghdlsynth')
-conflicts=('ghdlsynth-beta' 'ghdlsynth')
-makedepends=('git' 'yosys' 'clang')
-depends=('ghdl-git' 'gcc-libs')
+provides=('ghdl-yosys-plugin')
+conflicts=('ghdl-yosys-plugin' 'ghdlsynth-beta')
+replaces=('ghdlsynth-beta-git')
+# By default, this AUR package is linked against community/yosys and won't work
+# with yosys-git. If you want to use the plugin with yosys-git, it might be
+# easiest to just build it locally.
+makedepends=('git' 'clang')
+depends=('ghdl-git' 'yosys')
-source=("ghdlsynth::git://github.com/tgingold/ghdlsynth-beta.git")
+source=("git://github.com/ghdl/ghdl-yosys-plugin.git")
sha256sums=('SKIP')
# clang-9: error: unknown argument: '-fvar-tracking-assignments'
options=(!debug)
pkgver() {
- cd "${srcdir}/ghdlsynth"
+ cd "${srcdir}/ghdl-yosys-plugin"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "${srcdir}/ghdlsynth"
+ cd "${srcdir}/ghdl-yosys-plugin"
make ghdl.so
}
package() {
- cd "${srcdir}/ghdlsynth"
+ cd "${srcdir}/ghdl-yosys-plugin"
- install -Dm755 ghdl.so "$pkgdir/usr/lib/ghdl/ghdl_yosys.so"
+ install -Dm755 ghdl.so "$pkgdir/usr/lib/ghdl_yosys.so"
install -dm755 "$pkgdir/$(yosys-config --datdir)/plugins/"
- ln -s /usr/lib/ghdl/ghdl_yosys.so "$pkgdir/$(yosys-config --datdir)/plugins/ghdl.so"
+ ln -s /usr/lib/ghdl_yosys.so "$pkgdir/$(yosys-config --datdir)/plugins/ghdl.so"
- install -dm755 "$pkgdir/usr/share/ghdlsynth/examples/"
- cp -r examples/* "$pkgdir/usr/share/ghdlsynth/examples/"
+ install -dm755 "$pkgdir/usr/share/ghdl/yosys-plugin/examples/"
+ cp -r examples/* "$pkgdir/usr/share/ghdl/yosys-plugin/examples/"
}