summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuke Street2020-11-14 02:58:15 -0500
committerLuke Street2020-11-14 02:58:26 -0500
commit28c6082759ab2ea8d2c006ebc8a74018c56b5864 (patch)
treeff808cb4b385c7dc9be6a1284f7c584bd0a2142c
parentfac65087305f207d87e146bcf98760ec74a31285 (diff)
downloadaur-28c6082759ab2ea8d2c006ebc8a74018c56b5864.tar.gz
Update to 9.2
-rw-r--r--.SRCINFO7
-rw-r--r--2443.patch15
-rw-r--r--PKGBUILD19
3 files changed, 32 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index db67dd2930c6..d91b6c60b7ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ghidra-git
pkgdesc = Software reverse engineering framework (git)
- pkgver = 9.1.2+r831+gd9701df6d
+ pkgver = 9.2+r57+g8f1be0932
pkgrel = 1
url = https://www.nsa.gov/ghidra
arch = x86_64
@@ -9,7 +9,8 @@ pkgbase = ghidra-git
makedepends = gradle
makedepends = unzip
makedepends = fop
- depends = java-environment>=11
+ depends = java-runtime-common
+ depends = jdk11-openjdk
depends = bash
depends = hicolor-icon-theme
provides = ghidra
@@ -24,6 +25,7 @@ pkgbase = ghidra-git
source = https://sourceforge.net/projects/yajsw/files/yajsw/yajsw-stable-12.12/yajsw-stable-12.12.zip
source = https://sourceforge.net/projects/catacombae/files/HFSExplorer/0.21/hfsexplorer-0_21-bin.zip
source = ghidra.desktop
+ source = 2443.patch
sha512sums = SKIP
sha512sums = SKIP
sha512sums = c4a6c72ea09b58a44fcb8918cfada600467f10f99a02b53d2436ac68295e73c8daf9ba0a8bc7160ba1e28e87f032ee034435ebe40af35b6e2fe9fa4607581358
@@ -31,6 +33,7 @@ pkgbase = ghidra-git
sha512sums = 0ff5a228ae1c5251c8ba59f9bcd9b4a199b0caaf688f6eccba42c3d227784d8f56f9164b2fad73fc173ec314340c036144123ce152fe911013df5598bd708944
sha512sums = b85b4316115695acc78cc7c675c673058c05a238451562be0c6a48b2d11a28e5645a42cb62cdf063be015369df26201dfab6cf2e60f39e6468d1d53b23f94415
sha512sums = a85b8b3276e2ff4ed8bda6470c15d02711ebaa48463c775cd2a36549fad738e9fe073dab80f8c57646490ffc959cdc27e9d25b1dc2a5810b0ddb249b5dc99a9b
+ sha512sums = f659c42f50213fcd08770952292de23344a7e13e8412f538ffce8beea89bae0b260e0d0e88119f95218be56557db31ceb7365308657dc2bbb3d6af4a05321ec7
pkgname = ghidra-git
diff --git a/2443.patch b/2443.patch
new file mode 100644
index 000000000000..9b44916f032f
--- /dev/null
+++ b/2443.patch
@@ -0,0 +1,15 @@
+diff --git a/Ghidra/Features/Decompiler/src/main/help/help/TOC_Source.xml b/Ghidra/Features/Decompiler/src/main/help/help/TOC_Source.xml
+index 2317da834..20cd85554 100644
+--- a/Ghidra/Features/Decompiler/src/main/help/help/TOC_Source.xml
++++ b/Ghidra/Features/Decompiler/src/main/help/help/TOC_Source.xml
+@@ -68,7 +68,9 @@
+ text="Program Annotations Affecting the Decompiler"
+ target="help/topics/DecompilePlugin/DecompilerAnnotations.html">
+ <tocdef id="AnnoteFunctionBody" sortgroup="a" text="Machine Instructions" target="help/topics/DecompilePlugin/DecompilerAnnotations.html#AnnoteFunctionBody"/>
+- <tocdef id="AnnoteComments" sortgroup="b" text="Comments" target="help/topics/DecompilePlugin/DecompilerAnnotations.html#AnnoteComments"/>
++ <!-- Space added to text="Comments" attribute below to distinguish it from the CommentsPlugin section of the same name
++ https://github.com/NationalSecurityAgency/ghidra/issues/2443 -->
++ <tocdef id="AnnoteComments" sortgroup="b" text="Comments " target="help/topics/DecompilePlugin/DecompilerAnnotations.html#AnnoteComments"/>
+ <tocdef id="AnnoteVariables" sortgroup="c" text="Variable Annotations" target="help/topics/DecompilePlugin/DecompilerAnnotations.html#AnnoteVariables"/>
+ <tocdef id="AnnotePrototype" sortgroup="d" text="Function Prototypes" target="help/topics/DecompilePlugin/DecompilerAnnotations.html#AnnotePrototype"/>
+ <tocdef id="AnnoteMutability" sortgroup="e" text="Data Mutability" target="help/topics/DecompilePlugin/DecompilerAnnotations.html#AnnoteMutability"/>
diff --git a/PKGBUILD b/PKGBUILD
index ff62ba71314b..4938f0da0aa4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Danny Bautista <pyrolagus@gmail.com>
pkgname=ghidra-git
-pkgver=9.1.2+r831+gd9701df6d
+pkgver=9.2+r57+g8f1be0932
_d2j=2.0
_yajsw=12.12
_hfsx=0.21
@@ -14,7 +14,7 @@ _git=https://github.com/NationalSecurityAgency/ghidra
license=(Apache)
provides=(ghidra)
conflicts=(ghidra)
-depends=('java-environment>=11' bash hicolor-icon-theme)
+depends=(java-runtime-common jdk11-openjdk bash hicolor-icon-theme)
makedepends=(git gradle unzip fop)
source=(
git+$_git
@@ -24,6 +24,7 @@ source=(
https://sourceforge.net/projects/yajsw/files/yajsw/yajsw-stable-$_yajsw/yajsw-stable-$_yajsw.zip
https://sourceforge.net/projects/catacombae/files/HFSExplorer/$_hfsx/hfsexplorer-${_hfsx/./_}-bin.zip
ghidra.desktop
+ 2443.patch
)
noextract=(
AXMLPrinter2.jar
@@ -36,7 +37,8 @@ sha512sums=('SKIP'
'c1168ec913f1fbb0675915d4fd865ec9a8e8573f6c8aedcb6e68166f61f11aeaececc7548d54d78134843c0102c57d6350973f6d3027d0ffdae52a5c57a7f601'
'0ff5a228ae1c5251c8ba59f9bcd9b4a199b0caaf688f6eccba42c3d227784d8f56f9164b2fad73fc173ec314340c036144123ce152fe911013df5598bd708944'
'b85b4316115695acc78cc7c675c673058c05a238451562be0c6a48b2d11a28e5645a42cb62cdf063be015369df26201dfab6cf2e60f39e6468d1d53b23f94415'
- 'a85b8b3276e2ff4ed8bda6470c15d02711ebaa48463c775cd2a36549fad738e9fe073dab80f8c57646490ffc959cdc27e9d25b1dc2a5810b0ddb249b5dc99a9b')
+ 'a85b8b3276e2ff4ed8bda6470c15d02711ebaa48463c775cd2a36549fad738e9fe073dab80f8c57646490ffc959cdc27e9d25b1dc2a5810b0ddb249b5dc99a9b'
+ 'f659c42f50213fcd08770952292de23344a7e13e8412f538ffce8beea89bae0b260e0d0e88119f95218be56557db31ceb7365308657dc2bbb3d6af4a05321ec7')
pkgver() {
cd ghidra
@@ -45,13 +47,13 @@ pkgver() {
prepare() {
# HFSExplorer isn't archived in a folder, so let's make one to extract it into
- mkdir hfsx
- unzip hfsexplorer-${_hfsx/./_}-bin.zip -d hfsx
+ mkdir -p hfsx
+ unzip -o hfsexplorer-${_hfsx/./_}-bin.zip -d hfsx
cd ghidra
# Copy needed libraries into a flat repo
- mkdir flatRepo
+ mkdir -p flatRepo
cp ../dex2jar-$_d2j/lib/dex-*.jar \
../AXMLPrinter2.jar \
../hfsx/lib/{csframework,hfsx*,iharder-base64}.jar \
@@ -59,13 +61,16 @@ prepare() {
cp ../yajsw-stable-$_yajsw.zip Ghidra/Features/GhidraServer
# YAJSW expects this symlink
- ln -s ghidra ../ghidra.bin
+ ln -nsf ghidra ../ghidra.bin
# Add FID datasets
install -Dm 644 ../ghidra-data/FunctionID/*.fidb -t Ghidra/Features/FunctionID/src/main/fidb
# Ignore lack of licensing for YAJSW zip, packed FID datasets, and the native binaries
sed -i '/FileTree tree/a\\t\texclude "yajsw-stable-**.zip"\n\t\texclude "src/main/fidb/**.fidb"\n\t\texclude "os/linux64/**"' gradle/support/ip.gradle
+
+ # Patch for https://github.com/NationalSecurityAgency/ghidra/issues/2443
+ patch -Np1 -i "$srcdir"/2443.patch
}
build() {