summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2019-04-06 19:09:12 -0400
committerJean Lucas2019-04-06 19:15:16 -0400
commit58c7e5c02a68314785c2c53879303041e51a7cdd (patch)
tree021fd2aa6ce14c1fabc460b73d38e5915faecb85
parenta5c4f0a6d142c237a983e972ccf70e3be19e0284 (diff)
downloadaur-58c7e5c02a68314785c2c53879303041e51a7cdd.tar.gz
Add FID datasets
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
2 files changed, 14 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e99b02f9d1d1..1397b303a991 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Apr 6 05:50:31 UTC 2019
+# Sat Apr 6 23:04:34 UTC 2019
pkgbase = ghidra-git
pkgdesc = Software reverse engineering framework (git)
pkgver = 9.0.2+10+g49c2010
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/NationalSecurityAgency/ghidra
arch = x86_64
license = Apache
@@ -17,11 +17,13 @@ pkgbase = ghidra-git
noextract = yajsw-stable-12.12.zip
noextract = hfsexplorer-0_21-bin.zip
source = git+https://github.com/NationalSecurityAgency/ghidra
+ source = git+https://github.com/NationalSecurityAgency/ghidra-data
source = https://github.com/pxb1988/dex2jar/releases/download/2.0/dex-tools-2.0.zip
source = https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/android4me/AXMLPrinter2.jar
source = https://sourceforge.net/projects/yajsw/files/yajsw/yajsw-stable-12.12/yajsw-stable-12.12.zip
source = https://sourceforge.net/projects/catacombae/files/HFSExplorer/0.21/hfsexplorer-0_21-bin.zip
sha512sums = SKIP
+ sha512sums = SKIP
sha512sums = c4a6c72ea09b58a44fcb8918cfada600467f10f99a02b53d2436ac68295e73c8daf9ba0a8bc7160ba1e28e87f032ee034435ebe40af35b6e2fe9fa4607581358
sha512sums = c1168ec913f1fbb0675915d4fd865ec9a8e8573f6c8aedcb6e68166f61f11aeaececc7548d54d78134843c0102c57d6350973f6d3027d0ffdae52a5c57a7f601
sha512sums = 0ff5a228ae1c5251c8ba59f9bcd9b4a199b0caaf688f6eccba42c3d227784d8f56f9164b2fad73fc173ec314340c036144123ce152fe911013df5598bd708944
diff --git a/PKGBUILD b/PKGBUILD
index 55279a49b22d..2b118ebdcfef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgver=9.0.2+10+g49c2010
_d2j=2.0
_yajsw=12.12
_hfsx=0.21
-pkgrel=1
+pkgrel=2
pkgdesc='Software reverse engineering framework (git)'
arch=(x86_64)
url=https://github.com/NationalSecurityAgency/ghidra
@@ -14,6 +14,7 @@ conflicts=(ghidra ghidra-bin)
depends=('java-environment>=11' bash)
makedepends=(gradle unzip)
source=(git+$url
+ git+$url-data
https://github.com/pxb1988/dex2jar/releases/download/$_d2j/dex-tools-$_d2j.zip
https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/android4me/AXMLPrinter2.jar
https://sourceforge.net/projects/yajsw/files/yajsw/yajsw-stable-$_yajsw/yajsw-stable-$_yajsw.zip
@@ -22,6 +23,7 @@ noextract=(AXMLPrinter2.jar
yajsw-stable-$_yajsw.zip
hfsexplorer-${_hfsx/./_}-bin.zip)
sha512sums=('SKIP'
+ 'SKIP'
'c4a6c72ea09b58a44fcb8918cfada600467f10f99a02b53d2436ac68295e73c8daf9ba0a8bc7160ba1e28e87f032ee034435ebe40af35b6e2fe9fa4607581358'
'c1168ec913f1fbb0675915d4fd865ec9a8e8573f6c8aedcb6e68166f61f11aeaececc7548d54d78134843c0102c57d6350973f6d3027d0ffdae52a5c57a7f601'
'0ff5a228ae1c5251c8ba59f9bcd9b4a199b0caaf688f6eccba42c3d227784d8f56f9164b2fad73fc173ec314340c036144123ce152fe911013df5598bd708944'
@@ -53,7 +55,7 @@ allprojects {
}
EOF
- # Copy libs to common folder
+ # Add libs
install -Dm 644 ../dex2jar-$_d2j/lib/dex-*.jar \
../AXMLPrinter2.jar \
../hfsx/lib/{csframework,hfsx*,iharder-base64}.jar \
@@ -63,8 +65,11 @@ EOF
ln -sf ghidra ../ghidra.bin
install -Dm 644 ../yajsw-stable-$_yajsw.zip -t Ghidra/Features/GhidraServer
- # Fix bug where no license is found for the YAJSW zip
- sed -i '/FileTree tree/a\\t\texclude "yajsw-stable-**.zip"' gradleScripts/ip.gradle
+ # Ignore lack of licensing for YAJSW zip and packed FID datasets
+ sed -i '/FileTree tree/a\\t\texclude "yajsw-stable-**.zip"\n\t\texclude "src/main/fidb/**.fidb"' gradleScripts/ip.gradle
+
+ # Add FID datasets
+ install -Dm 644 ../ghidra-data/FunctionID/*.fidb -t Ghidra/Features/FunctionID/src/main/fidb
}
build() {
@@ -79,8 +84,7 @@ build() {
package() {
cd ghidra
install -d "$pkgdir"/{opt,usr/bin}
- _ghidra=ghidra_${pkgver:0:5}_PUBLIC_`date +"%Y%m%d"`_$_platform.zip
- unzip -u build/dist/$_ghidra -d "$pkgdir"/opt
+ unzip -u build/dist/ghidra_${pkgver:0:5}_PUBLIC_`date +"%Y%m%d"`_$_platform.zip -d "$pkgdir"/opt
mv "$pkgdir"/opt/ghidra{_${pkgver:0:5},}
ln -s /opt/ghidra/ghidraRun "$pkgdir"/usr/bin/ghidra
install -Dm 644 LICENSE "$pkgdir"/usr/share/licenses/ghidra/LICENSE