summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Rawlinson2021-05-26 01:00:35 +0000
committerGeorge Rawlinson2021-05-26 01:00:35 +0000
commit96405077466993b0b3d4e8922eb82307c40a0435 (patch)
tree4504db333445dce5961148bb0dd030d1fa11dfb0
parent04392ee7ec47f15003d4257fd79fe3b4165b1d13 (diff)
downloadaur-ghosts.tar.gz
upgpkg: ghosts 0.2.2-2
* Replaced tabs with spaces in PKGBUILD * Added a comment regarding the use of bsdtar/noextract
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad2effd4fb7f..f7e5f4557a0c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ghosts
pkgdesc = Tool to evaluate, compare & format host files
pkgver = 0.2.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/StevenBlack/ghosts
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 639f9d62f939..124576fbbdcc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=ghosts
pkgver=0.2.2
-pkgrel=1
+pkgrel=2
pkgdesc="Tool to evaluate, compare & format host files"
arch=('x86_64')
url="https://github.com/StevenBlack/ghosts"
@@ -13,12 +13,13 @@ b2sums=('21ec1aebc679a17e52c65ea77ca68ceb94429ae18e6734682525e958ecbd66d72a37778
noextract=("$pkgname-$pkgver.tar.gz")
prepare() {
+ # do not extract binaries
bsdtar -xf "$pkgname-$pkgver.tar.gz" \
--exclude "$pkgname-$pkgver/dist" \
--exclude "$pkgname-$pkgver/$pkgname"
# download dependencies
- cd "$pkgname-$pkgver"
+ cd "$pkgname-$pkgver"
go mod init "${url#https://}"
go mod tidy
@@ -27,7 +28,7 @@ prepare() {
}
build() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname-$pkgver"
export CGO_CPPFLAGS="${CPPFLAGS}"
export CGO_CFLAGS="${CFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
@@ -37,12 +38,12 @@ build() {
}
check() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname-$pkgver"
go test ./...
}
package() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname-$pkgver"
# binary
install -vDm755 -t "$pkgdir/usr/bin" "build/$pkgname"