summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2018-07-24 14:20:18 +0200
committerJakob Gahde2018-07-24 14:20:18 +0200
commit7a1e061866acb3794cbfa5b8f477e673aca02b45 (patch)
tree9c64c89dd1a2b3286d4d0e2d77bf3b284ec2bcab
parente9dc778ec2813c1c6314d6bc617a0ac9837ea22e (diff)
downloadaur-7a1e061866acb3794cbfa5b8f477e673aca02b45.tar.gz
ghostwriter 1.7.1-1: New version
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD26
2 files changed, 21 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 65cf0498f2fd..5861086f9498 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,23 @@
-# Generated by mksrcinfo v8
-# Thu May 17 09:30:14 UTC 2018
pkgbase = ghostwriter
pkgdesc = A cross-platform, aesthetic, distraction-free Markdown editor
- pkgver = 1.6.2
+ pkgver = 1.7.1
pkgrel = 1
url = https://github.com/wereturtle/ghostwriter
arch = i686
arch = x86_64
license = GPL3
makedepends = qt5-tools
+ depends = qt5-svg
depends = qt5-webkit
depends = hunspell
depends = hicolor-icon-theme
optdepends = multimarkdown: For alternative converter, superset of Markdown with various output formats
optdepends = pandoc: For Pandoc supported Markdown flavors and export to various formats
optdepends = cmark: For processing and rendering CommonMark
- source = https://github.com/wereturtle/ghostwriter/archive/v1.6.2.tar.gz
- md5sums = f799f8d8b27f82f41d605522643e51c6
+ source = https://github.com/wereturtle/ghostwriter/archive/v1.7.1.tar.gz
+ source = https://github.com/wereturtle/ghostwriter/compare/v1.7.1...c2d24150aec2890c42a0f5274a1bf941ee997175.patch
+ md5sums = 34122f91be26462048b6afb54cebef41
+ md5sums = a940d931e1b44afe4c6e07eb136d9021
pkgname = ghostwriter
diff --git a/PKGBUILD b/PKGBUILD
index 257e0e868f13..95b7fe9b8956 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,24 +4,31 @@
# Contributor: Philipp 'TamCore' B. <philipp [at] tamcore [dot] eu>
pkgname=ghostwriter
-pkgver=1.6.2
+pkgver=1.7.1
pkgrel=1
pkgdesc="A cross-platform, aesthetic, distraction-free Markdown editor"
arch=('i686' 'x86_64')
url="https://github.com/wereturtle/ghostwriter"
license=('GPL3')
-depends=('qt5-webkit' 'hunspell' 'hicolor-icon-theme')
+depends=('qt5-svg' 'qt5-webkit' 'hunspell' 'hicolor-icon-theme')
makedepends=('qt5-tools')
optdepends=('multimarkdown: For alternative converter, superset of Markdown with various output formats'
'pandoc: For Pandoc supported Markdown flavors and export to various formats'
'cmark: For processing and rendering CommonMark')
-source=("https://github.com/wereturtle/ghostwriter/archive/v${pkgver}.tar.gz")
-md5sums=('f799f8d8b27f82f41d605522643e51c6')
+source=("https://github.com/wereturtle/ghostwriter/archive/v${pkgver}.tar.gz"
+ "https://github.com/wereturtle/ghostwriter/compare/v1.7.1...c2d24150aec2890c42a0f5274a1bf941ee997175.patch")
+md5sums=('34122f91be26462048b6afb54cebef41'
+ 'a940d931e1b44afe4c6e07eb136d9021')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ patch -Np1 < "${srcdir}/v1.7.1...c2d24150aec2890c42a0f5274a1bf941ee997175.patch"
+}
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- lrelease translations/ghostwriter_*.ts
qmake PREFIX=/usr
make
}
@@ -31,13 +38,10 @@ package() {
make install INSTALL_ROOT="${pkgdir}"
- # Doc files
- install -Dm644 CREDITS.md \
+ install -Dm644 "CREDITS.md" \
"${pkgdir}/usr/share/doc/${pkgname}/CREDITS.md"
- install -Dm644 README.md \
+ install -Dm644 "README.md" \
"${pkgdir}/usr/share/doc/${pkgname}/README.md"
-
- # License for resources
- install -Dm644 resources/COPYING \
+ install -Dm644 "resources/COPYING" \
"${pkgdir}/usr/share/doc/${pkgname}/COPYING"
}