summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVinícius dos Santos Oliveira2015-06-14 02:07:13 -0300
committerVinícius dos Santos Oliveira2015-06-14 02:07:13 -0300
commitf1fa697eea25c9ffd981412014aa6bce53dbb464 (patch)
tree2ccf4763b256d250fbbda0c36974bce131b433c1
downloadaur-giieditor-git.tar.gz
Genesis commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD44
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e52424095636
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = giieditor-git
+ pkgdesc = It's the official animation editor of the BlowThemAll game.
+ pkgver = 20110830
+ pkgrel = 1
+ url = http://code.google.com/p/blowthemall/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = qt>=4.7.0
+ options = strip
+
+pkgname = giieditor-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..957ce0a32175
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Vinícius dos Santos Oliveira <vini.ipsmaker@gmail.com>
+pkgname=giieditor-git
+pkgver=20110830
+pkgrel=1
+pkgdesc="It's the official animation editor of the BlowThemAll game."
+arch=('i686' 'x86_64')
+url="http://code.google.com/p/blowthemall/"
+license=('GPL3')
+depends=('qt>=4.7.0')
+makedepends=('git')
+options=('strip')
+source=()
+md5sums=()
+
+_gitroot="https://code.google.com/p/blowthemall.giieditor/"
+_gitname="giieditor"
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [ -d $_gitname ] ; then
+ cd $_gitname && git pull origin
+ msg "The local files are updated."
+ else
+ git clone $_gitroot $_gitname
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting make..."
+
+ rm -rf "$srcdir/$_gitname-build"
+ git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+ cd "$srcdir/$_gitname-build"
+
+ qmake
+ make
+}
+
+package() {
+ cd "$pkgdir"
+ mkdir -p usr/bin
+ cp "$srcdir/$_gitname-build/giieditor" usr/bin
+}