summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2022-09-14 20:12:36 -0400
committerTed Alff2022-09-14 20:12:36 -0400
commit0037017530ccfcbaf85dc8f7a1ec3f591631a185 (patch)
tree30eef33a14cbc4085ea8eba3980fe54796888505
parent435788e268a538d8b5c66ca2c4c86561b929e006 (diff)
downloadaur-0037017530ccfcbaf85dc8f7a1ec3f591631a185.tar.gz
Fix build with libheif 1.13+
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 14 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f2ba3a78bdeb..2d52f88bd1cd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gimp-devel
pkgdesc = GNU Image Manipulation Program (Development version)
pkgver = 2.99.12
- pkgrel = 1
+ pkgrel = 2
url = https://www.gimp.org/
arch = i686
arch = x86_64
@@ -74,8 +74,10 @@ pkgbase = gimp-devel
provides = gimp=2.99.12
conflicts = gimp
source = https://download.gimp.org/pub/gimp/v2.99/gimp-2.99.12.tar.xz
+ source = fix_build_with_libheif_1.13.patch::https://gitlab.gnome.org/GNOME/gimp/-/commit/a61299ddb184babca015a846c72bf3e1a57faf2a.patch
source = linux.gpl
sha256sums = 7ba1b032ea520d540e4acad3da16d8637fe693743fdb36e0121775eea569f6a3
+ sha256sums = 6b3dbe50b85ec058f652b84ad7c959319618b8f5c23a9626face074ae3256aaf
sha256sums = 1003bbf5fc292d0d63be44562f46506f7b2ca5729770da9d38d3bb2e8a2f36b3
pkgname = gimp-devel
diff --git a/PKGBUILD b/PKGBUILD
index b28884a63b65..dc6a39ddca4f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=gimp
pkgname=${_pkgname}-devel
pkgver=2.99.12
-pkgrel=1
+pkgrel=2
pkgdesc="GNU Image Manipulation Program (Development version)"
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
url="https://www.gimp.org/"
@@ -34,9 +34,18 @@ optdepends=('gutenprint: for sophisticated printing only as gimp has built-in cu
'lua51-lgi: LUA scripting support')
conflicts=("${_pkgname}")
provides=("${_pkgname}=${pkgver}")
-source=(https://download.gimp.org/pub/gimp/v${pkgver%.*}/${_pkgname}-${pkgver}.tar.xz linux.gpl)
+source=("https://download.gimp.org/pub/gimp/v${pkgver%.*}/${_pkgname}-${pkgver}.tar.xz"
+ 'fix_build_with_libheif_1.13.patch::https://gitlab.gnome.org/GNOME/gimp/-/commit/a61299ddb184babca015a846c72bf3e1a57faf2a.patch'
+ 'linux.gpl')
sha256sums=('7ba1b032ea520d540e4acad3da16d8637fe693743fdb36e0121775eea569f6a3'
+ '6b3dbe50b85ec058f652b84ad7c959319618b8f5c23a9626face074ae3256aaf'
'1003bbf5fc292d0d63be44562f46506f7b2ca5729770da9d38d3bb2e8a2f36b3')
+
+prepare() {
+ cd "${_pkgname}-${pkgver}"
+ patch -Np1 -i ../fix_build_with_libheif_1.13.patch
+}
+
build() {
local meson_options=(
)