summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2022-12-10 14:21:26 -0500
committerTed Alff2022-12-10 14:21:26 -0500
commit5bb39a566fccf18a15b034249974b489ac54e5a3 (patch)
tree6730d9ad690429dfc73abb429dd1d6836d600bb6
parentd0b527975d79dbfe7d00a677f0fb30055a5e2e82 (diff)
downloadaur-5bb39a566fccf18a15b034249974b489ac54e5a3.tar.gz
Add patch to handle babl pkgconfig naming change from babl to babl-0.1. Update autotools PKGBUILD too.
-rw-r--r--PKGBUILD9
-rw-r--r--PKGBUILD.autotools16
2 files changed, 20 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 79cf1d58a546..20719b4f8d5b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=gimp
pkgname=${_pkgname}-devel
pkgver=2.99.14
-pkgrel=1
+pkgrel=2
pkgdesc="GNU Image Manipulation Program (Development version)"
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
url="https://www.gimp.org/"
@@ -35,10 +35,17 @@ optdepends=('gutenprint: for sophisticated printing only as gimp has built-in cu
conflicts=("${_pkgname}")
provides=("${_pkgname}=${pkgver}")
source=("https://download.gimp.org/pub/gimp/v${pkgver%.*}/${_pkgname}-${pkgver}.tar.xz"
+ 'babl-0.1-name-change-meson.patch::https://gitlab.gnome.org/GNOME/gimp/-/commit/04a78154e1af5e30dcedde6dbaa321be3f0e24b1.patch'
'linux.gpl')
sha256sums=('313a205475d1ff03c5c4d9602f09f5c975ba6c1c79d8843e2396f9fe2abdf7a8'
+ '40c8175505598219e379bfd25c3b0a37bbd42ac35c06990683f1dca622a0a6a1'
'1003bbf5fc292d0d63be44562f46506f7b2ca5729770da9d38d3bb2e8a2f36b3')
+prepare() {
+ cd "${_pkgname}-${pkgver}"
+ patch -Np1 -i ../babl-0.1-name-change-meson.patch
+}
+
build() {
local meson_options=(
)
diff --git a/PKGBUILD.autotools b/PKGBUILD.autotools
index 567dc8f92e79..de2832f8272c 100644
--- a/PKGBUILD.autotools
+++ b/PKGBUILD.autotools
@@ -2,15 +2,15 @@
_pkgname=gimp
pkgname=${_pkgname}-devel
-pkgver=2.99.12
-pkgrel=1
+pkgver=2.99.14
+pkgrel=2
pkgdesc="GNU Image Manipulation Program (Development version)"
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
url="https://www.gimp.org/"
license=('GPL' 'LGPL')
depends=('gtk3' 'lcms2' 'libwmf' 'icu' 'enchant' 'libgexiv2' 'librsvg' 'desktop-file-utils'
'libexif' 'libgudev' 'openjpeg2' 'poppler-glib' 'poppler-data' 'openexr' 'mypaint-brushes1'
- 'babl>=0.1.78' 'gegl>=0.4.38' 'cairo' 'python-gobject' 'appstream-glib' 'libxmu' 'graphviz')
+ 'babl>=0.1.98' 'gegl>=0.4.40' 'cairo' 'python-gobject' 'appstream-glib' 'libxmu' 'graphviz')
makedepends=('intltool' 'libxslt' 'glib-networking'
'alsa-lib' 'curl' 'ghostscript' 'libxpm'
'libheif' 'libwebp' 'libmng' 'iso-codes' 'aalib' 'zlib' 'libjxl'
@@ -34,9 +34,17 @@ optdepends=('gutenprint: for sophisticated printing only as gimp has built-in cu
'lua51-lgi: LUA scripting support')
conflicts=("${_pkgname}")
provides=("${_pkgname}=${pkgver}")
-source=(https://download.gimp.org/pub/gimp/v${pkgver%.*}/${_pkgname}-${pkgver}-autotools.tar.bz2 linux.gpl)
+source=("https://download.gimp.org/pub/gimp/v${pkgver%.*}/${_pkgname}-${pkgver}-autotools.tar.bz2"
+ 'babl-0.1-name-change-autotools.patch::https://gitlab.gnome.org/GNOME/gimp/-/commit/09ece8f6f99756ed84ded47d9da6e2f5cbda5375.patch'
+ 'linux.gpl')
sha256sums=('028bb8f825c492037d09720694c3a3096f1af5d6347eaa84970b43c476713ee7'
'1003bbf5fc292d0d63be44562f46506f7b2ca5729770da9d38d3bb2e8a2f36b3')
+
+prepare() {
+ cd "${_pkgname}-${pkgver}"
+ patch -Np1 -i ../babl-0.1-name-change-autotools.patch
+}
+
build() {
cd "${_pkgname}-${pkgver}"
./configure \