summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Morgan2021-08-04 18:13:42 +1200
committerChris Morgan2021-08-04 18:16:49 +1200
commitf30a6cb8f041faf3ebe45d978d7a567311e5b2cd (patch)
tree9c79bee4795ff47b225b963eba094d83757c92d3
parent3d5d8ce8f12def7440b3647adc2773aa3cb5d115 (diff)
downloadaur-gimp-plugin-gmic-git.tar.gz
Fix `makepkg --printsrcinfo`
Running makepkg directly worked fine, but apparently at least paru would go running `makepkg --printsrcinfo` itself and baulk at the extra lines, which I had previously manually removed from .SRCINFO, believing it to not really matter. Once I discovered it *did* matter, I looked into /usr/bin/makepkg to find out how to detect --printsrcinfo. Probably not a great way of doing it, but it’ll probably do it. This fixes the issue surfaced by electricprism in https://aur.archlinux.org/packages/gimp-plugin-gmic-git/#comment-820310
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d652fb624f21..86ab6b6a2c67 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gimp-plugin-gmic-git
pkgdesc = Front-end to the image processing framework G'MICQ
- pkgver = 2.9.7.r82.gda87d71.gimp.2.0
+ pkgver = 2.9.8.r13.g2885531.gimp.2.0
pkgrel = 1
url = https://github.com/c-koi/gmic-qt
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index b0fb3ff07b4a..9b1084f7372c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname='gimp-plugin-gmic-git'
_name='gmic'
-pkgver=2.9.7.r82.gda87d71.gimp.2.0
+pkgver=2.9.8.r13.g2885531.gimp.2.0
pkgrel=1
pkgdesc="Front-end to the image processing framework G'MICQ"
url="https://github.com/c-koi/${_name}-qt"
@@ -32,10 +32,10 @@ _try_gimp_version() {
# _gimp_version should be "2.0", "2.99" or "3.0"; it can be specified by passing an environment variable in, or it can be discovered.
# (Ideally this might possibly be multiple distinct packages, but I’m not sure, since packages like gimp and gimp-devel conflict anyway, so at the least I don’t think they’d be produced from a common pkgbase.)
-msg "Choosing GIMP major version to build for..."
+(( PRINTSRCINFO )) || msg "Choosing GIMP major version to build for..."
if [ -n "$_gimp_version" ]; then
if _try_gimp_version "$_gimp_version"; then
- msg2 "Using $_gimp_version (from _gimp_version environment variable)"
+ (( PRINTSRCINFO )) || msg2 "Using $_gimp_version (from _gimp_version environment variable)"
else
error "_gimp_version was manually set to '$_gimp_version', but I don’t know what to do with that (known values are '2.0', '2.99' and '3.0')"
exit 1
@@ -48,7 +48,7 @@ else
fi
done
if [ -n "$_gimp_version" ]; then
- msg2 "Using $_gimp_version (found installed locally)"
+ (( PRINTSRCINFO )) || msg2 "Using $_gimp_version (found installed locally)"
else
error "Couldn’t determine GIMP version, make sure you have a GIMP package installed"
exit 1