summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2023-06-30 23:53:30 +0300
committerAdrian Perez de Castro2023-06-30 23:53:30 +0300
commit528d91267b011251e99f98f1be9f25830fbab467 (patch)
tree579b2cd83b6ea3f18b032b2ceed8b68d40f8046f
parentf1c16dda75e295dca56323198072b74a1f866ca0 (diff)
downloadaur-git-archive-all.tar.gz
Bump to version 1.23.1
While at it, switch to python-build
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD11
2 files changed, 13 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e37ba75a5699..8050fa6eadd0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,17 @@
pkgbase = git-archive-all
pkgdesc = Wrapper for git-archive that archives a git superproject and its submodules
- pkgver = 1.23.0
+ pkgver = 1.23.1
pkgrel = 1
url = https://github.com/Kentzo/git-archive-all
arch = any
license = custom:MIT
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ makedepends = python-setuptools
depends = git
- depends = python-setuptools
conflicts = git-archive-all-git
- source = https://github.com/Kentzo/git-archive-all/releases/download/1.23.0/git-archive-all-1.23.0.tar.gz
- sha512sums = 6d5b97088b8a153d25c05d926b81a95382bfc730263b152a07292cc35756f80d1d25342db946a83b96c3e064bc001195bda89c2ca697acd338c30fd3320e6c44
+ source = https://github.com/Kentzo/git-archive-all/releases/download/1.23.1/git-archive-all-1.23.1.tar.gz
+ b2sums = 63699ab19e0862577e4296bf48160cddcdfeb9fdbf7fa4854769bf7c3faed617ce9af5312a3d119dff77ce354c783e480c70e2135bce076f6ed85f4a38e61f08
pkgname = git-archive-all
diff --git a/PKGBUILD b/PKGBUILD
index e0c8ca020979..3cc759da8b16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,24 @@
# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
pkgname=git-archive-all
pkgdesc='Wrapper for git-archive that archives a git superproject and its submodules'
-pkgver=1.23.0
+pkgver=1.23.1
pkgrel=1
url=https://github.com/Kentzo/git-archive-all
license=(custom:MIT)
-depends=(git python-setuptools)
+depends=(git)
+makedepends=(python-build python-installer python-wheel python-setuptools)
conflicts=(git-archive-all-git)
arch=(any)
source=("${url}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz")
-sha512sums=('6d5b97088b8a153d25c05d926b81a95382bfc730263b152a07292cc35756f80d1d25342db946a83b96c3e064bc001195bda89c2ca697acd338c30fd3320e6c44')
+b2sums=('63699ab19e0862577e4296bf48160cddcdfeb9fdbf7fa4854769bf7c3faed617ce9af5312a3d119dff77ce354c783e480c70e2135bce076f6ed85f4a38e61f08')
build () {
cd "${pkgname}-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package () {
cd "${pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+ python -m installer --destdir="${pkgdir}" dist/*.whl
install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}