summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzer0-x2023-04-16 03:27:54 +0300
committerzer0-x2023-04-16 03:27:54 +0300
commit9ac8038b7736bc1d5548e6da39e7dcf1df03d58e (patch)
tree44ce027dfba8d22b060dd9327409b31b286ba3f0
parenta84598364db36a13a226d6213c69b653dd9a6ff3 (diff)
downloadaur-git-cm-git.tar.gz
Improve how version are handled
Just selecet tags for versions.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e6deff69cb39..f0e7641adb9f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = git-cm-git
pkgdesc = Easily create conventional-commits friendly commit messages for git
- pkgver = 0.2.3.r3.g67cb397
+ pkgver = 0.2.3
pkgrel = 1
url = https://github.com/mainrs/git-cm
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index d1a108a16f77..8868cc86625a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname="git-cm-git"
_pkgname=${pkgname%-git}
-pkgver="0.2.3.r3.g67cb397"
+pkgver=0.2.3
pkgrel=1
pkgdesc="Easily create conventional-commits friendly commit messages for git"
arch=("x86_64")
@@ -17,11 +17,14 @@ sha512sums=("SKIP")
pkgver() {
cd "${pkgname}"
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --tags --abbrev=0 --match 'v*' | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
cd "${pkgname}"
+
+ git reset --hard "$(git describe --tags --abbrev=0 --match 'v*')"
+
cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
}