summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Weingardt2015-06-13 02:17:46 +0200
committerPaul Weingardt2015-06-13 02:17:46 +0200
commit283898450178a3a10e866576c81bebe2f26b68f5 (patch)
tree17c8c5956a5620d1438d0bf4a23a4061ad4aa4a6
downloadaur-283898450178a3a10e866576c81bebe2f26b68f5.tar.gz
initial commit, v2.1.2
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD26
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dcd40b1ffce8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = git-cola
+ pkgdesc = A powerful GUI for Git
+ pkgver = 2.1.2
+ pkgrel = 1
+ url = http://git-cola.github.com/
+ arch = any
+ license = GPL
+ makedepends = asciidoc
+ makedepends = docbook-xsl
+ makedepends = rsync
+ makedepends = xmlto
+ makedepends = python-sphinx>=1.1.3
+ depends = git
+ depends = python-pyqt4>=4.4
+ depends = icu
+ optdepends = python-pyinotify>=0.7.1: for inotify support
+ optdepends = tk: to use the built-in ssh-askpass handler
+ options = !makeflags
+ source = https://github.com/git-cola/git-cola/archive/v2.1.2.zip
+ sha256sums = 16fff73d2fd30bebdecce6f6179e87d6a03304e98819177de06055ead74d0f69
+
+pkgname = git-cola
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2078fece93ad
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+## Ignore everything
+*
+
+## Except:
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..551c46ad9908
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Paul Weingardt <paulweingardt@web.de>
+# Contributor: TDY <tdy@gmx.com>
+pkgname=git-cola
+pkgver=2.1.2
+pkgrel=1
+pkgdesc="A powerful GUI for Git"
+arch=('any')
+url="http://git-cola.github.com/"
+license=('GPL')
+depends=('git' 'python-pyqt4>=4.4' 'icu')
+makedepends=('asciidoc' 'docbook-xsl' 'rsync' 'xmlto' 'python-sphinx>=1.1.3')
+optdepends=('python-pyinotify>=0.7.1: for inotify support'
+'tk: to use the built-in ssh-askpass handler')
+options=('!makeflags')
+source=("https://github.com/git-cola/git-cola/archive/v$pkgver.zip")
+sha256sums=('16fff73d2fd30bebdecce6f6179e87d6a03304e98819177de06055ead74d0f69')
+
+build() {
+ cd "$srcdir/${pkgname}-$pkgver"
+ make all doc html
+}
+
+package() {
+ cd "$srcdir/${pkgname}-$pkgver"
+ make prefix=/usr DESTDIR="$pkgdir" install{,-doc,-html}
+}