summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornoobping2022-04-20 15:01:57 +0200
committernoobping2022-04-20 15:01:57 +0200
commitd13457b4ed0266479f7f71905b9533af74aa6c57 (patch)
tree0f36b6f456aba6d29fbf739eeb964eb1c98ed776
downloadaur-git-estimate-bin.tar.gz
Release v1.1.0: Merge branch 'cadam11-master'
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore13
-rw-r--r--PKGBUILD18
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..611086b9bf9d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = git-estimate-bin
+ pkgdesc = Estimates hours and days spent by all developers on a git repository
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://github.com/luigitni/git-estimate
+ arch = x86_64
+ license = MIT
+ makedepends = zip
+ depends = git-hours
+ source = https://github.com/luigitni/git-estimate/releases/download/v1.1.0/git-estimate-linux-amd64.zip
+ sha512sums = 50a63747721a8a7de1f65ea654f96efef57a32a80d341ccdf061fbc982658b5a2b35080c269beba60aab5274e8cfb188bba1d96f0a061b1e226e88f520e47390
+
+pkgname = git-estimate-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1e2b0c0734b7
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,13 @@
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..797498d9129d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: noobping <hello@noobping.dev>
+pkgname=git-estimate-bin
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="Estimates hours and days spent by all developers on a git repository "
+arch=('x86_64')
+url="https://github.com/luigitni/git-estimate"
+license=('MIT')
+depends=('git-hours')
+makedepends=('zip')
+source=("$url/releases/download/v${pkgver}/${pkgname%-bin}-linux-amd64.zip")
+sha512sums=('50a63747721a8a7de1f65ea654f96efef57a32a80d341ccdf061fbc982658b5a2b35080c269beba60aab5274e8cfb188bba1d96f0a061b1e226e88f520e47390')
+validpgpkeys=()
+
+package() {
+ mkdir -p "$pkgdir"/usr/bin
+ install -m 555 "${srcdir}"/${pkgname%-bin}-linux-amd64 "$pkgdir"/usr/bin/${pkgname%-bin}
+}