summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKamran Mackey2015-12-08 04:46:37 -0700
committerKamran Mackey2015-12-08 04:46:37 -0700
commit24937639725b3d19118688e90e3ce0221149b74d (patch)
tree3d64f3db2dcda6f3de8ba1132bec600223b07550
parent53105938574bc0ecee5b4fdd58a6e03a97f196f9 (diff)
downloadaur-24937639725b3d19118688e90e3ce0221149b74d.tar.gz
There we go.
Added the systemd unit files to the source array. Signed-off-by: Kamran Mackey <kamranm1200@gmail.com>
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
-rw-r--r--git-daemon.socket9
-rw-r--r--git-daemon@.service10
4 files changed, 34 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96af7968b020..f4c33f582aae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Tue Dec 8 11:33:49 UTC 2015
+# Tue Dec 8 11:46:36 UTC 2015
pkgbase = git-git
pkgdesc = A fast distributed version control system
pkgver = v2.6.3.r469.ge5da865
@@ -21,7 +21,11 @@ pkgbase = git-git
provides = git
conflicts = git
source = git://github.com/git/git.git
+ source = git-daemon@.service
+ source = git-daemon.socket
md5sums = SKIP
+ md5sums = 042524f942785772d7bd52a1f02fe5ae
+ md5sums = f67869315c2cc112e076f0c73f248002
pkgname = git-git
diff --git a/PKGBUILD b/PKGBUILD
index ea746721b6bf..88fb2e5a5ae7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,8 +13,12 @@ depends=('git' 'asciidoc' 'gettext' 'openssl' 'expat' 'xmlto' 'curl' 'zlib' 'per
conflicts=('git')
provides=('git')
install=git-git.install
-source=(git://github.com/git/git.git)
-md5sums=('SKIP')
+source=("git://github.com/git/git.git"
+ git-daemon@.service
+ git-daemon.socket)
+md5sums=('SKIP'
+ '042524f942785772d7bd52a1f02fe5ae'
+ 'f67869315c2cc112e076f0c73f248002')
_gitname=git
pkgver() {
@@ -42,4 +46,8 @@ build() {
package() {
cd "$_gitname"
make DESTDIR="$pkgdir" install install-doc
+
+ # git-daemon via systemd socket activation
+ install -D -m 644 "$srcdir"/git-daemon@.service "$pkgdir"/usr/lib/systemd/system/git-daemon@.service
+ install -D -m 644 "$srcdir"/git-daemon.socket "$pkgdir"/usr/lib/systemd/system/git-daemon.socket
}
diff --git a/git-daemon.socket b/git-daemon.socket
new file mode 100644
index 000000000000..58ed2f154600
--- /dev/null
+++ b/git-daemon.socket
@@ -0,0 +1,9 @@
+[Unit]
+Description=Git Daemon Socket
+
+[Socket]
+ListenStream=9418
+Accept=true
+
+[Install]
+WantedBy=sockets.target
diff --git a/git-daemon@.service b/git-daemon@.service
new file mode 100644
index 000000000000..55ca7141b31a
--- /dev/null
+++ b/git-daemon@.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Git Daemon Instance
+
+[Service]
+User=git
+# The '-' is to ignore non-zero exit statuses
+ExecStart=-/usr/lib/git-core/git-daemon --inetd --export-all --base-path=/srv/git
+StandardInput=socket
+StandardOutput=inherit
+StandardError=journal