summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÓscar García Amor2021-04-24 10:29:01 +0200
committerÓscar García Amor2021-04-24 10:29:01 +0200
commit3be7618b18edb16b9559931886cb40ce635e1b36 (patch)
tree22ff04d886975e6167c36371fe18dec4dd36447c
parentf23c786882edb76464ec823453c0a533688008eb (diff)
downloadaur-git-sizer.tar.gz
upgpkg: git-sizer 1.4.0-1
upstream release
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 8 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5b2ff03fcba2..a93331ada1c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = git-sizer
pkgdesc = Compute various size metrics for a Git repository, flagging those that might cause problems
- pkgver = 1.3.0
+ pkgver = 1.4.0
pkgrel = 1
url = https://github.com/github/git-sizer
arch = i686
@@ -11,8 +11,8 @@ pkgbase = git-sizer
license = MIT
makedepends = go
depends = git
- source = https://github.com/github/git-sizer/archive/951a51bd37e5e3454850d471b05d9d51d4851b74.tar.gz
- sha256sums = 22491d77f5a694b9e1ea0596884a99fe5b1e409e9bed6b07cb834b5361311f77
+ source = https://github.com/github/git-sizer/archive/v1.4.0.tar.gz
+ sha256sums = 5dafc4014d6bfae40e678d72c0a67a29cd9ac7b38a0894fc75ab8c05a9064a4b
pkgname = git-sizer
diff --git a/PKGBUILD b/PKGBUILD
index 25b0ddb6a576..5832b1efe627 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,7 @@
# Maintainer: "Amhairghin" Oscar Garcia Amor (https://ogarcia.me)
-_commit="951a51bd37e5e3454850d471b05d9d51d4851b74"
pkgname=git-sizer
-pkgver=1.3.0
+pkgver=1.4.0
pkgrel=1
pkgdesc='Compute various size metrics for a Git repository, flagging those that might cause problems'
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
@@ -10,13 +9,11 @@ url='https://github.com/github/git-sizer'
license=('MIT')
depends=('git')
makedepends=('go')
-#source=("https://github.com/github/${pkgname}/archive/v${pkgver}.tar.gz")
-source=("https://github.com/github/${pkgname}/archive/${_commit}.tar.gz")
-sha256sums=('22491d77f5a694b9e1ea0596884a99fe5b1e409e9bed6b07cb834b5361311f77')
+source=("https://github.com/github/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('5dafc4014d6bfae40e678d72c0a67a29cd9ac7b38a0894fc75ab8c05a9064a4b')
build() {
- #cd "${pkgname}-${pkgver}"
- cd "${pkgname}-${_commit}"
+ cd "${pkgname}-${pkgver}"
export CGO_CPPFLAGS="${CPPFLAGS}"
export CGO_CFLAGS="${CFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
@@ -26,8 +23,7 @@ build() {
}
package() {
- #cd "${pkgname}-${pkgver}"
- cd "${pkgname}-${_commit}"
+ cd "${pkgname}-${pkgver}"
# binary
install -D -m755 git-sizer "${pkgdir}/usr/bin/git-sizer"
# doc files