summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2022-01-19 13:27:46 +0300
committerCaleb Maclennan2022-01-19 13:27:46 +0300
commit98c29db6438c0467f8ff45e734e23edf40f50901 (patch)
tree1a30b62ea667ffe1df5b691fa0045644e8193db4
parent5fa042b9de47f3d58c26cb1093afca4d3b2f9d38 (diff)
downloadaur-98c29db6438c0467f8ff45e734e23edf40f50901.tar.gz
upgpkg: git-town 7.6.0-3
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a5010daa93cd..7df38352f3ac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = git-town
pkgdesc = Generic, high-level Git workflow support
pkgver = 7.6.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/git-town/git-town
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 9b2bd07d974a..fcf7b541393d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=git-town
pkgver=7.6.0
-pkgrel=2
+pkgrel=3
pkgdesc='Generic, high-level Git workflow support'
url="https://github.com/$pkgname/$pkgname"
arch=(x86_64)
@@ -25,10 +25,16 @@ build() {
-modcacherw \
-ldflags "-X $_varpath.version=$pkgver -X $_varpath.buildDate=$_date -linkmode external -extldflags \"${LDFLAGS}\"" \
.
+ for s in bash fish zsh; do
+ ./$pkgname completions $s > completions.$s
+ done
}
package() {
cd "$_archive"
install -Dm0755 -t "$pkgdir/usr/bin/" "$pkgname"
install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE
+ install -Dm0644 completions.bash "$pkgdir/usr/share/bash-completion/completions/$pkgname"
+ install -Dm0644 completions.fish "$pkgdir/usr/share/fish/vendor_completions.d/$pkgname.fish"
+ install -Dm0644 completions.zsh "$pkgdir/usr/share/zsh/site-functions/_$pkgname"
}