summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-28 11:54:35 +0800
committerzxp198210052024-03-28 11:54:35 +0800
commit48466d56c09e760197ae5309c691a374a53eaf80 (patch)
treed625003908ea6868e5ca1ef8fb7a85712c8ae99b
parentea89728be1f950223de3d127f60260e117a48761 (diff)
downloadaur-48466d56c09e760197ae5309c691a374a53eaf80.tar.gz
update to 5.1.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD25
2 files changed, 20 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9e071fb0b399..42e72d0069ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gitify
pkgdesc = GitHub notifications on your menu bar.
- pkgver = 5.0.0
+ pkgver = 5.1.0
pkgrel = 1
url = https://www.gitify.io/
arch = any
@@ -11,10 +11,10 @@ pkgbase = gitify
makedepends = pnpm
makedepends = git
makedepends = icoutils
- depends = electron19-bin
- source = gitify.git::git+https://github.com/gitify-app/gitify.git#tag=v5.0.0
+ depends = electron29
+ source = gitify.git::git+https://github.com/gitify-app/gitify.git#tag=v5.1.0
source = gitify.sh
- sha256sums = 6dbccd1f7621d69d97b340ac9d012bb7acada2d9dcc44bde10530b14b7d581aa
+ sha256sums = 0b54b880a75e27831fb741b084fbede6c6f0700be6d6945675db678f1cad5f59
sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
pkgname = gitify
diff --git a/PKGBUILD b/PKGBUILD
index a00331e98c25..b1346d61e5de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,9 @@
# Contributor: PolpOnline <aur at t0mmy dot anonaddy dot com>
pkgname=gitify
_pkgname=Gitify
-pkgver=5.0.0
-_electronversion=19
+pkgver=5.1.0
+_electronversion=29
+_nodeversion=20
pkgrel=1
pkgdesc="GitHub notifications on your menu bar."
arch=('any')
@@ -11,7 +12,7 @@ url='https://www.gitify.io/'
_ghurl="https://github.com/gitify-app/gitify"
license=('MIT')
depends=(
- "electron${_electronversion}-bin"
+ "electron${_electronversion}"
)
makedepends=(
'gendesk'
@@ -25,15 +26,21 @@ source=(
"${pkgname}.git::git+${_ghurl}.git#tag=v${pkgver}"
"${pkgname}.sh"
)
-sha256sums=('6dbccd1f7621d69d97b340ac9d012bb7acada2d9dcc44bde10530b14b7d581aa'
+sha256sums=('0b54b880a75e27831fb741b084fbede6c6f0700be6d6945675db678f1cad5f59'
'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
+_ensure_local_nvm() {
+ export NVM_DIR="${srcdir}/.nvm"
+ source /usr/share/nvm/init-nvm.sh || [[ $? != 1 ]]
+ nvm install "${_nodeversion}"
+ nvm use "${_nodeversion}"
+}
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname}|g" \
-e "s|@runname@|app.asar|g" \
- -e "s|@options@||g" \
+ -e "s|@options@|env ELECTRON_OZONE_PLATFORM_HINT=auto|g" \
-i "${srcdir}/${pkgname}.sh"
- gendesk -f -n -q --categories="Utility" --name="${_pkgname}" --exec="${pkgname} %U"
+ gendesk -f -n -q --categories="Development" --name="${_pkgname}" --exec="${pkgname} %U"
cd "${srcdir}/${pkgname}.git"
export npm_config_build_from_source=true
export ELECTRON_SKIP_BINARY_DOWNLOAD=1
@@ -46,9 +53,9 @@ build() {
pnpm config set cache-dir "${srcdir}/.pnpm_cache"
pnpm config set link-workspace-packages true
if [ `curl -s ipinfo.io/country | grep CN | wc -l ` -ge 1 ];then
- echo 'registry="https://registry.npmmirror.com/"' >> .npmrc
- echo 'electron_mirror="https://registry.npmmirror.com/-/binary/electron/"' >> .npmrc
- echo 'electron_builder_binaries_mirror="https://registry.npmmirror.com/-/binary/electron-builder-binaries/"' >> .npmrc
+ export npm_config_registry=https://registry.npmmirror.com
+ export npm_config_electron_mirror=https://registry.npmmirror.com/-/binary/electron/
+ export npm_config_electron_builder_binaries_mirror=https://registry.npmmirror.com/-/binary/electron-builder-binaries/
else
echo "Your network is OK."
fi