summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAurélien Ooms2017-05-01 19:04:43 +0200
committerAurélien Ooms2017-05-01 19:04:43 +0200
commit0b4f85d871f095935c6818d77f57c6805f8e70f9 (patch)
treefc35d7c85cdb5705d7f1f128a38dacb7d70bc09e
downloadaur-gitkv.tar.gz
1.0.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0ce7c0331c8c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gitkv
+ pkgdesc = Easy key-value storage via git
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/aureooms/gitkv
+ arch = any
+ license = AGPL-3.0
+ makedepends = git
+ depends = bash
+ depends = coreutils
+ depends = git
+ source = https://github.com/aureooms/gitkv/archive/v1.0.0.tar.gz
+ md5sums = SKIP
+
+pkgname = gitkv
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dad8b7f41698
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Aurélien Ooms <aurelien.ooms@gmail.com>
+pkgname=gitkv
+pkgver=1.0.0
+pkgrel=1
+epoch=
+pkgdesc="Easy key-value storage via git"
+arch=(any)
+url="https://github.com/aureooms/${pkgname}"
+license=('AGPL-3.0')
+groups=()
+depends=('bash' 'coreutils' 'git')
+makedepends=('git')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+source=("https://github.com/aureooms/${pkgname}/archive/v${pkgver}.tar.gz")
+noextract=()
+md5sums=('SKIP')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}