summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobin Candau2022-09-13 12:34:55 +0200
committerRobin Candau2022-09-13 12:34:55 +0200
commit0e7698f8e1d99adb5a8ee07d6a910b376318201a (patch)
treec60a4cc1497b6d8a49c9f6a8a66817207805a5a2
parent3eb946231512f1fc55a8e8c36a6c18d61e7bd399 (diff)
downloadaur-0e7698f8e1d99adb5a8ee07d6a910b376318201a.tar.gz
Added the MIT license to '/usr/share/licenses/gitmux/LICENSE'
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 8 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 52452de0a33d..dc37d3012c73 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gitmux-bin
pkgdesc = Git in your tmux status bar
pkgver = 0.7.9
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/arl/gitmux
arch = x86_64
arch = i686
@@ -10,6 +10,8 @@ pkgbase = gitmux-bin
depends = tmux
provides = gitmux
conflicts = gitmux
+ source = https://raw.githubusercontent.com/arl/gitmux/main/LICENSE
+ sha256sums = 051c31312c5af0e4e4d2559546a8a0f36ce2bf9b50e2d00a81e6a3b31666a3ec
source_x86_64 = gitmux-0.7.9-amd64.tar.gz::https://github.com/arl/gitmux/releases/download/v0.7.9/gitmux_0.7.9_linux_amd64.tar.gz
sha256sums_x86_64 = 156f98946cc437572576c69f062f287e4d0e5a98855bd47cd6a2f15c9e385107
source_i686 = gitmux-0.7.9-386.tar.gz::https://github.com/arl/gitmux/releases/download/v0.7.9/gitmux_0.7.9_linux_386.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 1d24bb57ac18..52fb63efb6db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=gitmux-bin
_pkgname="${pkgname%-bin}"
pkgver=0.7.9
-pkgrel=2
+pkgrel=3
pkgdesc="Git in your tmux status bar"
arch=('x86_64' 'i686' 'aarch64')
url="https://github.com/arl/gitmux"
@@ -11,9 +11,11 @@ license=('MIT')
depends=('tmux')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
+source=("https://raw.githubusercontent.com/arl/gitmux/main/LICENSE")
source_x86_64=("${_pkgname}-${pkgver}-amd64.tar.gz::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_amd64.tar.gz")
source_i686=("${_pkgname}-${pkgver}-386.tar.gz::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_386.tar.gz")
source_aarch64=("${_pkgname}-${pkgver}-arm64.tar.gz::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_arm64.tar.gz")
+sha256sums=('051c31312c5af0e4e4d2559546a8a0f36ce2bf9b50e2d00a81e6a3b31666a3ec')
sha256sums_x86_64=('156f98946cc437572576c69f062f287e4d0e5a98855bd47cd6a2f15c9e385107')
sha256sums_i686=('60ad0033546362bd016e6c820637358b07e08aae999e5ec0956311be115767f7')
sha256sums_aarch64=('959111d5de93aecc87cb706cc3729fce93b27b3a31a7bfbc4d9d1bc7bb93391e')
@@ -22,4 +24,6 @@ package() {
cd "${srcdir}"
install -Dm 755 "${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+
+ install -Dm 644 "LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
}