summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobin Candau2022-09-12 21:35:40 +0200
committerRobin Candau2022-09-12 21:35:40 +0200
commit507bce29e5eed63085dc324df243f13ade715522 (patch)
tree015c50abf0ff2fe33a075f71a4b397f5e73d70c0
downloadaur-507bce29e5eed63085dc324df243f13ade715522.tar.gz
Initial Release
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD25
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d33eebfdf667
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = gitmux-bin
+ pkgdesc = Git in your tmux status bar
+ pkgver = 0.7.9
+ pkgrel = 1
+ url = https://github.com/arl/gitmux
+ arch = x86_64
+ arch = i686
+ arch = aarch64
+ license = MIT
+ depends = tmux
+ provides = gitmux
+ conflicts = gitmux
+ source_x86_64 = gitmux-0.7.9.tar.gz::https://github.com/arl/gitmux/releases/download/v0.7.9/gitmux_0.7.9_linux_amd64.tar.gz
+ sha256sums_x86_64 = 156f98946cc437572576c69f062f287e4d0e5a98855bd47cd6a2f15c9e385107
+ source_i686 = gitmux-0.7.9.tar.gz::https://github.com/arl/gitmux/releases/download/v0.7.9/gitmux_0.7.9_linux_386.tar.gz
+ sha256sums_i686 = 60ad0033546362bd016e6c820637358b07e08aae999e5ec0956311be115767f7
+ source_aarch64 = gitmux-0.7.9.tar.gz::https://github.com/arl/gitmux/releases/download/v0.7.9/gitmux_0.7.9_linux_arm64.tar.gz
+ sha256sums_aarch64 = 959111d5de93aecc87cb706cc3729fce93b27b3a31a7bfbc4d9d1bc7bb93391e
+
+pkgname = gitmux-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4a11120768ba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Robin Candau <robincandau[at]protonmail[dot]com>
+
+pkgname=gitmux-bin
+_pkgname="${pkgname%-bin}"
+pkgver=0.7.9
+pkgrel=1
+pkgdesc="Git in your tmux status bar"
+arch=('x86_64' 'i686' 'aarch64')
+url="https://github.com/arl/gitmux"
+license=('MIT')
+depends=('tmux')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source_x86_64=("${_pkgname}-${pkgver}.tar.gz::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_amd64.tar.gz")
+source_i686=("${_pkgname}-${pkgver}.tar.gz::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_386.tar.gz")
+source_aarch64=("${_pkgname}-${pkgver}.tar.gz::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_arm64.tar.gz")
+sha256sums_x86_64=('156f98946cc437572576c69f062f287e4d0e5a98855bd47cd6a2f15c9e385107')
+sha256sums_i686=('60ad0033546362bd016e6c820637358b07e08aae999e5ec0956311be115767f7')
+sha256sums_aarch64=('959111d5de93aecc87cb706cc3729fce93b27b3a31a7bfbc4d9d1bc7bb93391e')
+
+package() {
+ cd "${srcdir}"
+
+ install -Dm 755 "${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+}