summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartins Mozeiko2016-06-09 11:56:03 -0700
committerMartins Mozeiko2016-06-09 11:56:03 -0700
commit1ba9c0e152e40b533187278d3b81606c470de151 (patch)
treee29f8dd47b969cb83d0f23c78d91840c1808bbdd
parent6c1a6e223b813f235065a81f2c70440d0c46aaed (diff)
downloadaur-1ba9c0e152e40b533187278d3b81606c470de151.tar.gz
update to commit 6dfe549
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD10
-rw-r--r--add_x11_library.patch10
4 files changed, 19 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2f274aa4660e..c4be20d11963 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = glcapsviewer-git
pkgdesc = OpenGL Hardware Capability Viewer
- pkgver = r109.b635159
- pkgrel = 2
+ pkgver = r112.6dfe549
+ pkgrel = 1
url = http://www.saschawillems.de/?page_id=771/
arch = i686
arch = x86_64
@@ -13,11 +13,11 @@ pkgbase = glcapsviewer-git
depends = glfw
depends = qt5-base
source = git+https://github.com/SaschaWillems/glCapsViewer
- source = https://github.com/proudzhu/glCapsViewer/commit/45044a7a0c754d95f6ae9c63ff25b6b107878651.patch
+ source = add_x11_library.patch
source = glcapsviewer.desktop
source = glcapsviewer
sha256sums = SKIP
- sha256sums = fe350e9391cf76ad18ddea4e04e4f9be86dd3375440a64216cf17fa092854248
+ sha256sums = SKIP
sha256sums = 3ff750cda95917ff93388dd373437b12129427bc33e52343247bf69bf1d24c02
sha256sums = 139ceb073a34bea5450ca2b6d7f50523f8986d9f5a6b069d36cf05d03609f352
diff --git a/.gitignore b/.gitignore
index 5ed89c365d62..d9e90f429df1 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,3 @@
-*.patch
*.xz
src
pkg
diff --git a/PKGBUILD b/PKGBUILD
index d346650e0d21..2ce5bc1783ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
# Maintainer: Martins Mozeiko <martins.mozeiko@gmail.com>
pkgname=glcapsviewer-git
-pkgver=r109.b635159
-pkgrel=2
+pkgver=r112.6dfe549
+pkgrel=1
pkgdesc='OpenGL Hardware Capability Viewer'
url='http://www.saschawillems.de/?page_id=771/'
arch=('i686' 'x86_64')
license=('GPL3')
source=('git+https://github.com/SaschaWillems/glCapsViewer'
- 'https://github.com/proudzhu/glCapsViewer/commit/45044a7a0c754d95f6ae9c63ff25b6b107878651.patch'
+ 'add_x11_library.patch'
'glcapsviewer.desktop'
'glcapsviewer')
sha256sums=('SKIP'
- 'fe350e9391cf76ad18ddea4e04e4f9be86dd3375440a64216cf17fa092854248'
+ '0d622a96a3bf458726e94cb7a3125dd97db9edd7665a1c4277904f350d3335e4'
'3ff750cda95917ff93388dd373437b12129427bc33e52343247bf69bf1d24c02'
'139ceb073a34bea5450ca2b6d7f50523f8986d9f5a6b069d36cf05d03609f352')
makedepends=('git' 'cmake' 'boost')
@@ -26,7 +26,7 @@ pkgver() {
prepare() {
cd "$srcdir"/glCapsViewer
- patch -p1 -i "$srcdir"/45044a7a0c754d95f6ae9c63ff25b6b107878651.patch
+ patch -p1 -i "$srcdir"/add_x11_library.patch
}
package() {
diff --git a/add_x11_library.patch b/add_x11_library.patch
new file mode 100644
index 000000000000..96223832860d
--- /dev/null
+++ b/add_x11_library.patch
@@ -0,0 +1,10 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 37668da..5bdd38b 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -82,4 +82,5 @@ target_link_libraries(${NAME} ${GLEW_LIBRARIES})
+ target_link_libraries(${NAME} ${OPENGL_LIBRARIES})
+ target_link_libraries(${NAME} ${Boost_LIBRARIES})
+ target_link_libraries(${NAME} glfw ${GLFW_LIBRARY})
++target_link_libraries(${NAME} -lX11)
+