summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmmanuel Gil Peyrot2018-02-06 12:30:24 +0100
committerEmmanuel Gil Peyrot2018-02-06 12:30:24 +0100
commitb353f1e33e2da7f0c3502b97100fc3829352939d (patch)
tree76b191d86ad03ea9642e74e531e6ad57ee386e90
parenta793cc9683e72b22f3633bf6acf788e0099a1b8b (diff)
downloadaur-b353f1e33e2da7f0c3502b97100fc3829352939d.tar.gz
Make the libgl dependency optional, and add Vulkan too.
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6a328065c29a..f7043aa1478c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@ arch=('i686' 'x86_64' 'armv7h')
url="http://www.glfw.org/"
license=('custom:ZLIB')
optdepends=('doxygen: build glfw html documentation')
-makedepends=('cmake' 'extra-cmake-modules' 'git' 'libxi' 'libxrandr' 'libxinerama' 'libxcursor' 'wayland' 'wayland-protocols' 'libxkbcommon' 'libgl')
+makedepends=('cmake' 'extra-cmake-modules' 'git' 'libxi' 'libxrandr' 'libxinerama' 'libxcursor' 'wayland' 'wayland-protocols' 'libxkbcommon')
conflicts=("$_pkgbase")
provides=("$_pkgbase=3.3")
source=("$_pkgbase::git+https://github.com/glfw/glfw")
@@ -52,7 +52,11 @@ build() {
}
package_glfw-x11-git() {
- depends=('libxi' 'libxrandr' 'libxinerama' 'libxcursor' 'libgl')
+ depends=('libxi' 'libxrandr' 'libxinerama' 'libxcursor')
+ optdepends=('libgl: for OpenGL support'
+ 'opengl-driver: for OpenGL support'
+ 'vulkan-icd-loader: for Vulkan support'
+ 'vulkan-driver: for Vulkan support')
pkgdesc="A free, open source, portable framework for OpenGL application development. (git, X11 version)"
cd $_pkgbase/build-x11
@@ -61,7 +65,11 @@ package_glfw-x11-git() {
}
package_glfw-wayland-git() {
- depends=('wayland' 'libxkbcommon' 'libgl')
+ depends=('wayland' 'libxkbcommon')
+ optdepends=('libgl: for OpenGL support'
+ 'opengl-driver: for OpenGL support'
+ 'vulkan-icd-loader: for Vulkan support'
+ 'vulkan-driver: for Vulkan support')
pkgdesc="A free, open source, portable framework for OpenGL application development. (git, Wayland version)"
cd $_pkgbase/build-wayland