summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Hipp2015-06-15 16:59:03 +1200
committerThomas Hipp2015-06-15 16:59:03 +1200
commit644db36d9b7221f652119f754b855e9dcf0f0348 (patch)
treebd5544184c45a6c56352befdde2a8588fd52afd2
downloadaur-glimpse-git.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
-rw-r--r--glimpse-git.install27
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0c21454110ea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = glimpse-git
+ pkgdesc = GLIMPSE measurement client.
+ pkgver = 2.3.5.r9.g550d6e1
+ pkgrel = 1
+ url = https://www.measure-it.net
+ install = glimpse-git.install
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ makedepends = qt5-base
+ source = git://github.com/HSAnet/glimpse_client.git#branch=master
+ sha256sums = SKIP
+
+pkgname = glimpse-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..169645518ee7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Thomas Hipp <thomashipp (at) gmail (dot) com>
+
+pkgname=glimpse-git
+pkgver=2.3.5.r9.g550d6e1
+pkgrel=1
+pkgdesc='GLIMPSE measurement client.'
+arch=('i686' 'x86_64')
+url='https://www.measure-it.net'
+license=('BSD')
+makedepends=('git' 'qt5-base')
+install=glimpse-git.install
+source=('git://github.com/HSAnet/glimpse_client.git#branch=master')
+sha256sums=('SKIP')
+
+_gitname=glimpse_client
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+ git describe --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${_gitname}"
+ qmake
+ make
+}
+
+package() {
+ cd "${_gitname}"
+ make INSTALL_ROOT="$pkgdir/" install
+ install -Dm644 LICENSE.txt \
+ ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
diff --git a/glimpse-git.install b/glimpse-git.install
new file mode 100644
index 000000000000..6d9ff41761a7
--- /dev/null
+++ b/glimpse-git.install
@@ -0,0 +1,27 @@
+post_install() {
+ useradd --system --create-home --home-dir /var/lib/glimpse \
+ --shell /sbin/nologin glimpse &>/dev/null
+ echo ":: You need to register an account prior to starting the"
+ echo " service. This can be done with glimpse-console, e.g.:"
+ echo " glimpse-console --register-anonymous OR"
+ echo " glimpse-console --register foobar@example.com"
+ echo
+ echo " If you already have an account you can login with one of"
+ echo " the following commands. Note that this will not keep"
+ echo " the application running but just write the settings."
+ echo " glimpse-console --login foobar@example.com OR"
+ echo " sudo -u glimpse glimpse-console --login foobar@example.com"
+ echo
+ echo " To enable/start the probe, run:"
+ echo " systemctl enable glimpse-probe.service"
+ echo " systemctl start glimpse-probe.service"
+ echo
+ echo " Note that glimpse-probe.service runs as user glimpse"
+ echo " and therefore needs the config to be in /var/lib/glimpse."
+}
+
+post_upgrade() {
+ getent passwd glimpse &>/dev/null || useradd --system \
+ --create-home --home-dir /var/lib/glimpse \
+ --shell /sbin/nologin glimpse &>/dev/null
+}