summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorchron2015-07-21 13:18:56 +0200
committerchron2015-07-21 13:18:56 +0200
commitc5a792262bc3c43e4543dd9da6ecfa87e9445979 (patch)
treec52c8574868533c7eb71ce01d0db1d2a32622a8f
downloadaur-glogic.tar.gz
Copied kusakata files from AUR3, minor changes
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD27
-rw-r--r--glogic.install11
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bff1093164c5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = glogic
+ pkgdesc = An educational graphical logic circuit simulator
+ pkgver = 2.6
+ pkgrel = 2
+ url = https://launchpad.net/glogic
+ install = glogic.install
+ arch = any
+ license = GPL3
+ makedepends = itstool
+ depends = hicolor-icon-theme
+ depends = intltool
+ depends = python
+ depends = python-cairo
+ source = https://launchpad.net/glogic/trunk/2.6/+download/glogic-2.6.tar.gz
+ sha256sums = 62fabbc39aa7d72491fb83aa0547385cbb89d7a593ad2fb80b019607593d1bde
+
+pkgname = glogic
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a4de6c454fb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Contributor kusakata <shohei atmark kusakata period com>
+# Maintainer chron <chronischzuspaet at gmail dot com>>
+
+pkgname=glogic
+pkgver=2.6
+pkgrel=2
+pkgdesc='An educational graphical logic circuit simulator'
+arch=('any')
+url="https://launchpad.net/glogic"
+license=('GPL3')
+depends=('hicolor-icon-theme' 'intltool' 'python' 'python-cairo')
+makedepends=('itstool')
+install=glogic.install
+source=("https://launchpad.net/glogic/trunk/${pkgver}/+download/glogic-${pkgver}.tar.gz")
+
+build() {
+ cd "${srcdir}/glogic-${pkgver}"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/glogic-${pkgver}"
+ make DESTDIR="$pkgdir" install
+}
+
+sha256sums=('62fabbc39aa7d72491fb83aa0547385cbb89d7a593ad2fb80b019607593d1bde')
diff --git a/glogic.install b/glogic.install
new file mode 100644
index 000000000000..17ca8f78a655
--- /dev/null
+++ b/glogic.install
@@ -0,0 +1,11 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}