summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Poulin2016-07-22 18:35:06 -0400
committerMaxime Poulin2016-07-22 18:35:06 -0400
commit557a73628153292b3c632e582962ff3163db2977 (patch)
treea6a8af621c7f4cb3a7f2abc359dc63bb3d9c23af
parentf9f3e292828049c7047c71bdaed1402f918d59c3 (diff)
downloadaur-glxosd-git.tar.gz
Fix building, thanks lubosz!
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD24
2 files changed, 21 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29d5a6168583..1296ddf9848b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# ven jui 22 22:35:02 UTC 2016
pkgbase = glxosd-git
pkgdesc = An OSD for OpenGL applications running under the X Window System. This allows you to monitor your framerate and hardware temperature in games on Linux!
- pkgver = r32.9f216b2
+ pkgver = r192.97d8a7d
pkgrel = 1
url = https://github.com/nickguletskii/GLXOSD
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 7b50c6f2687f..d9a4aeda1b3f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Maxime Poulin <maxpoulin64@gmail.com>
# Contributor: xpander <xpander0@gmail.com>
pkgname=glxosd-git
-_gitname=glxosd
-pkgver=r32.9f216b2
+_gitname=GLXOSD
+pkgver=r192.97d8a7d
pkgrel=1
pkgdesc="An OSD for OpenGL applications running under the X Window System. This allows you to monitor your framerate and hardware temperature in games on Linux!"
arch=('i686' 'x86_64')
@@ -20,6 +20,11 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "$srcdir/$_gitname"
+ git submodule init
+ git submodule update --recursive
+}
build() {
cd "$srcdir/GLXOSD"
@@ -28,8 +33,15 @@ build() {
}
package() {
- cd "$srcdir/GLXOSD"
- make DESTDIR="$pkgdir/" install
- sed -i 's+/usr//lib/x86_64-linux-gnu//glxosd/+/usr/lib/glxosd+g' $pkgdir/usr/bin/glxosd
- sed -i 's+/usr//lib/i386-linux-gnu//glxosd+/usr/lib/glxosd+g' $pkgdir/usr/bin/glxosd
+ cd "$srcdir/$_gitname"
+ make DESTDIR="$pkgdir/" install
+
+ if [ -d "$pkgdir/usr/lib64" ]; then
+ mv "$pkgdir/usr/lib64" "$pkgdir/usr/lib"
+ fi
+
+ sed -i 's+/usr//lib/x86_64-linux-gnu//glxosd/+/usr/lib/glxosd+g' \
+ "$pkgdir/usr/bin/glxosd"
+ sed -i 's+/usr//lib/i386-linux-gnu//glxosd+/usr/lib/glxosd+g' \
+ "$pkgdir/usr/bin/glxosd"
}