summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornot_anonymous2015-07-05 18:07:08 -0600
committernot_anonymous2015-07-05 18:07:08 -0600
commit7329a5935149a1e98b98b9027c84ddada54c14fb (patch)
treecdfed0c0886f8c7373e48c5f9782df2200eee79d
downloadaur-gmfsk.tar.gz
Initial import
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD58
-rw-r--r--gmfsk.desktop14
-rw-r--r--gmfsk.install26
-rw-r--r--gmfsk.patch158
5 files changed, 283 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e2d42658c5a8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = gmfsk
+ pkgdesc = Ham Radio multi-mode digital communications package.
+ pkgver = 0.7pre1
+ pkgrel = 3
+ url = http://gmfsk.connect.fi/
+ install = gmfsk.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = gnome-doc-utils>=0.11.2
+ makedepends = imagemagick
+ depends = fftw2
+ depends = libgnomeui
+ depends = desktop-file-utils
+ depends = alsa-oss
+ source = http://gmfsk.connect.fi/gmfsk-0.7pre1.tar.gz
+ source = gmfsk.patch
+ source = gmfsk.desktop
+ md5sums = 62bf63530f67eff2b757e7e46507a275
+ md5sums = 6b94a17094f2a7d7344b2ab11f1192a9
+ md5sums = 3f5850161cf523e21aafa00d264f6ad6
+ sha256sums = bf4ef74f5f540eb41f265497e84c787ee4070e6e5728fcbfdb6ff4802fe979b1
+ sha256sums = 25124c748335e09d95cc6f20822e29d6c73068c78ccda334ef73a926cfdf2275
+ sha256sums = 93b500ab79b92c97d96bd282023439acb2405463aa7ed05921cf6e2f1d0c9072
+
+pkgname = gmfsk
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9844d0bf487f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: not_anonymous <nmlibertarian@gmail.com>
+# Contributor: Gordon JC Pearce <aur@gjcp.net>
+# Original Contributor: Bob Finch <w9ya@arrl.net>
+
+pkgname=gmfsk
+pkgver=0.7pre1
+pkgrel=3
+pkgdesc="Ham Radio multi-mode digital communications package."
+arch=('i686' 'x86_64')
+url="http://gmfsk.connect.fi/"
+license=('GPL')
+depends=('fftw2' 'libgnomeui' 'desktop-file-utils' 'alsa-oss')
+# ** Note: this is an oss-based app, see:
+# man aoss (in the alsa-oss package) AND
+# arch-wiki/alsa about using oss & loading drivers
+# ** critical (needed/loaded) driver is "snd-pcm-oss" **
+makedepends=('gnome-doc-utils>=0.11.2' 'imagemagick')
+install=$pkgname.install
+source=(http://gmfsk.connect.fi/$pkgname-$pkgver.tar.gz
+ gmfsk.patch
+ $pkgname.desktop
+)
+
+prepare() {
+ cd $srcdir/$pkgname-$pkgver
+
+ patch -p1 < $srcdir/gmfsk.patch
+ convert pixmaps/tune.xpm $pkgname.png
+}
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+
+ ./configure --prefix=/usr --sysconfdir=/etc --disable-schemas-install
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+
+ make GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 DESTDIR="${pkgdir}" install
+
+ install -dm755 $pkgdir/usr/share/gconf/schemas
+ gconf-merge-schema $pkgdir/usr/share/gconf/schemas/${pkgname}.schemas --domain gmfsk \
+ $pkgdir/etc/gconf/schemas/*.schemas
+
+ rm -rf $pkgdir/etc
+ rm -rf $pkgdir/usr/share/omf
+
+ install -Dm644 ../$pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
+ install -Dm644 $pkgname.png $pkgdir/usr/share/pixmaps/$pkgname.png
+}
+md5sums=('62bf63530f67eff2b757e7e46507a275'
+ '6b94a17094f2a7d7344b2ab11f1192a9'
+ '3f5850161cf523e21aafa00d264f6ad6')
+sha256sums=('bf4ef74f5f540eb41f265497e84c787ee4070e6e5728fcbfdb6ff4802fe979b1'
+ '25124c748335e09d95cc6f20822e29d6c73068c78ccda334ef73a926cfdf2275'
+ '93b500ab79b92c97d96bd282023439acb2405463aa7ed05921cf6e2f1d0c9072')
diff --git a/gmfsk.desktop b/gmfsk.desktop
new file mode 100644
index 000000000000..1a390120d12d
--- /dev/null
+++ b/gmfsk.desktop
@@ -0,0 +1,14 @@
+[Desktop Entry]
+Name=gMFSK
+Name[en_US]=gMFSK
+Comment=Ham Radio client for Digital modes
+Comment[en_US]=Ham Radio client for Digital modes
+Exec=gmfsk
+Icon=gmfsk
+MimeType=text/plain;
+StartupNotify=true
+Terminal=false
+Type=Application
+Categories=Application;HamRadio;
+X-DCOP-ServiceType=none
+X-KDE-SubstituteUID=false
diff --git a/gmfsk.install b/gmfsk.install
new file mode 100644
index 000000000000..7959c4a99139
--- /dev/null
+++ b/gmfsk.install
@@ -0,0 +1,26 @@
+pkgname=gmfsk
+
+post_install() {
+ usr/sbin/gconfpkg --install ${pkgname}
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+ glib-compile-schemas usr/share/glib-2.0/schemas
+}
+
+pre_upgrade() {
+ pre_remove $1
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ usr/sbin/gconfpkg --uninstall ${pkgname}
+}
+
+post_remove() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ glib-compile-schemas usr/share/glib-2.0/schemas
+}
diff --git a/gmfsk.patch b/gmfsk.patch
new file mode 100644
index 000000000000..b5bd0152d679
--- /dev/null
+++ b/gmfsk.patch
@@ -0,0 +1,158 @@
+diff --git a/src/misc/misc.c b/src/misc/misc.c
+index 14b1320..8bd3f59 100644
+--- a/src/misc/misc.c
++++ b/src/misc/misc.c
+@@ -103,25 +103,6 @@ guint8 rbits8(guint8 w)
+ /* ---------------------------------------------------------------------- */
+
+ /*
+- * Integer base-2 logarithm
+- */
+-guint log2(guint x)
+-{
+- int y = 0;
+-
+- x >>= 1;
+-
+- while (x) {
+- x >>= 1;
+- y++;
+- }
+-
+- return y;
+-}
+-
+-/* ---------------------------------------------------------------------- */
+-
+-/*
+ * Gray encoding and decoding (8 bit)
+ */
+ guint8 grayencode(guint8 data)
+diff --git a/src/misc/misc.h b/src/misc/misc.h
+index 083de73..6a9cf30 100644
+--- a/src/misc/misc.h
++++ b/src/misc/misc.h
+@@ -105,25 +105,6 @@ extern inline guint8 rbits8(guint8 w)
+ /* ---------------------------------------------------------------------- */
+
+ /*
+- * Integer base-2 logarithm
+- */
+-extern inline guint log2(guint x)
+-{
+- int y = 0;
+-
+- x >>= 1;
+-
+- while (x) {
+- x >>= 1;
+- y++;
+- }
+-
+- return y;
+-}
+-
+-/* ---------------------------------------------------------------------- */
+-
+-/*
+ * Gray encoding and decoding (8 bit)
+ */
+ extern inline guint8 grayencode(guint8 data)
+diff --git a/src/olivia/mfsk.h b/src/olivia/mfsk.h
+index 288bed3..4d5f28c 100644
+--- a/src/olivia/mfsk.h
++++ b/src/olivia/mfsk.h
+@@ -1960,7 +1960,7 @@ template <class Type=float>
+
+ Type *ModulatorOutput;
+
+- RateConverter<Type> RateConverter; // output rate converter
++ RateConverter<Type> xRateConverter; // output rate converter
+
+ Type *ConverterOutput;
+
+@@ -1982,7 +1982,7 @@ template <class Type=float>
+ Encoder.Free();
+ Modulator.Free();
+ free(ModulatorOutput); ModulatorOutput=0;
+- RateConverter.Free();
++ xRateConverter.Free();
+ free(ConverterOutput); ConverterOutput=0; }
+
+ // set default primary parameters
+@@ -2027,8 +2027,8 @@ template <class Type=float>
+ if(ReallocArray(&ModulatorOutput,Modulator.SymbolSepar)<0) goto Error;
+
+ // preset the rate converter
+- RateConverter.OutputRate=OutputSampleRate/SampleRate;
+- if(RateConverter.Preset()<0) goto Error;
++ xRateConverter.OutputRate=OutputSampleRate/SampleRate;
++ if(xRateConverter.Preset()<0) goto Error;
+
+ MaxOutputLen=(size_t)ceil(Modulator.SymbolSepar*OutputSampleRate/SampleRate+2);
+ if(ReallocArray(&ConverterOutput,MaxOutputLen)<0) goto Error;
+@@ -2046,7 +2046,7 @@ template <class Type=float>
+ Monitor.Reset();
+ SymbolPtr=0;
+ State=0;
+- RateConverter.Reset(); }
++ xRateConverter.Reset(); }
+
+ Type BaudRate(void)
+ { return SampleRate/Modulator.SymbolSepar; }
+@@ -2102,7 +2102,7 @@ template <class Type=float>
+ { Modulator.Send(Encoder.OutputBlock[SymbolPtr]);
+ SymbolPtr+=1; if(SymbolPtr>=SymbolsPerBlock) SymbolPtr=0; }
+ int ModLen=Modulator.Output(ModulatorOutput);
+- int ConvLen=RateConverter.Process(ModulatorOutput,ModLen,ConverterOutput);
++ int ConvLen=xRateConverter.Process(ModulatorOutput,ModLen,ConverterOutput);
+ if(ConvLen<0) return ConvLen;
+ ConvertToS16(ConverterOutput,Buffer,ConvLen);
+ return ConvLen; }
+@@ -2209,7 +2209,7 @@ template <class Type=float>
+
+ private:
+
+- RateConverter<Type> RateConverter;
++ RateConverter<Type> xRateConverter;
+
+ Seq<Type> InputBuffer;
+
+@@ -2267,7 +2267,7 @@ template <class Type=float>
+ DecodePipe[Idx].Free();
+ free(DecodePipe); DecodePipe=0; }
+
+- RateConverter.Free();
++ xRateConverter.Free();
+ InputBuffer.Free();
+ InputProcessor.Free();
+ Demodulator.Free();
+@@ -2305,8 +2305,8 @@ template <class Type=float>
+ BitsPerSymbol=Log2(Tones);
+ Tones=Exp2(BitsPerSymbol);
+
+- RateConverter.OutputRate=SampleRate/InputSampleRate;
+- if(RateConverter.Preset()<0) goto Error;
++ xRateConverter.OutputRate=SampleRate/InputSampleRate;
++ if(xRateConverter.Preset()<0) goto Error;
+
+ Demodulator.BitsPerSymbol=BitsPerSymbol;
+ Demodulator.SymbolLen=Exp2(BitsPerSymbol+7-Log2(Bandwidth/125));
+@@ -2383,7 +2383,7 @@ template <class Type=float>
+ void Reset(void)
+ { size_t Idx;
+
+- RateConverter.Reset();
++ xRateConverter.Reset();
+
+ InputBuffer.Clear();
+
+@@ -2458,7 +2458,7 @@ template <class Type=float>
+ // process an audio batch: first the input processor, then the demodulator
+ template <class InpType>
+ int Process(InpType *Input, size_t InputLen)
+- { if(RateConverter.Process(Input, InputLen, InputBuffer)<0) return -1;
++ { if(xRateConverter.Process(Input, InputLen, InputBuffer)<0) return -1;
+ ProcessInputBuffer();
+ return 0; }
+