summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2021-11-20 10:44:59 +0330
committerMohammadreza Abdollahzadeh2021-11-20 10:44:59 +0330
commit89225490c65d636c988d755cf087095f93f5ed68 (patch)
tree9981c8d3d1bd16ed0f8bddd95f024406e426dff6
parenta5f861c67e5cb7aaff9f44c2a74901e96cd45753 (diff)
downloadaur-89225490c65d636c988d755cf087095f93f5ed68.tar.gz
fix PKGBUILD
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD25
2 files changed, 13 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8faa94ce4a9c..99b6d99f7cfb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,11 @@
-# Generated by mksrcinfo v8
-# Thu Jul 20 13:11:03 UTC 2017
pkgbase = gmt-coast
pkgdesc = The full resolution coastline dataset for the Generic Mapping Tools.
pkgver = 2.3.7
- pkgrel = 1
- url = http://gmt.soest.hawaii.edu/
+ pkgrel = 2
+ url = https://www.generic-mapping-tools.org/
arch = any
license = LGPL
- source = ftp://ftp.soest.hawaii.edu/gshhg/gshhg-gmt-2.3.7.tar.gz
- md5sums = 8ee2653f9daf84d49fefbf990bbfa1e7
+ source = https://github.com/GenericMappingTools/gshhg-gmt/releases/download/2.3.7/gshhg-gmt-2.3.7.tar.gz
+ sha256sums = 9bb1a956fca0718c083bef842e625797535a00ce81f175df08b042c2a92cfe7f
pkgname = gmt-coast
-
diff --git a/PKGBUILD b/PKGBUILD
index a0dd997bce31..85f9b1c3451b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,18 @@
+# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
# Contributor: Benjamin Sick
pkgname=gmt-coast
pkgver=2.3.7
-pkgrel=1
+pkgrel=2
pkgdesc="The full resolution coastline dataset for the Generic Mapping Tools."
arch=('any')
-url="http://gmt.soest.hawaii.edu/"
+url="https://www.generic-mapping-tools.org/"
license=('LGPL')
-depends=()
-makedepends=()
-provides=()
-source=(ftp://ftp.soest.hawaii.edu/gshhg/gshhg-gmt-${pkgver}.tar.gz)
-md5sums=('8ee2653f9daf84d49fefbf990bbfa1e7')
-
-build() {
- echo "Nothing to build."
-}
+source=("https://github.com/GenericMappingTools/gshhg-gmt/releases/download/${pkgver}/gshhg-gmt-${pkgver}.tar.gz")
+sha256sums=('9bb1a956fca0718c083bef842e625797535a00ce81f175df08b042c2a92cfe7f')
package() {
- mkdir -p ${pkgdir}/usr/share/gmt/coast
- install -m 644 $startdir/src/gshhg-gmt-${pkgver}/binned* \
- ${pkgdir}/usr/share/gmt/coast
+ mkdir -p ${pkgdir}/usr/share/gmt/coast
+ install -m 644 gshhg-gmt-${pkgver}/*.nc \
+ ${pkgdir}/usr/share/gmt/coast/
}
-
-# vim:set ts=2 sw=2 et:
+# vim:set ts=4 sw=4: