summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBlackleg2015-09-25 12:28:53 +0200
committerBlackleg2015-09-25 12:28:53 +0200
commit03a5204ef9c0f912882641325855d50895db3514 (patch)
treeaf82a594d2a29048550f75166096176ee54df9fa
downloadaur-gnoduino.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD43
-rw-r--r--gnoduino.install23
4 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..52deca33d233
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = gnoduino
+ pkgdesc = An implementation of well-known Arduino IDE for GNOME
+ pkgver = 0.5.2
+ pkgrel = 1
+ url = http://gnome.eu.org/index.php/Gnoduino
+ install = gnoduino.install
+ arch = any
+ license = GPL
+ makedepends = python2-distribute
+ depends = avr-libc
+ depends = avrdude
+ depends = avr-binutils
+ depends = avr-gcc
+ depends = pyxdg
+ depends = pygtksourceview2
+ depends = python2-pyserial
+ depends = python2-gconf
+ depends = desktop-file-utils
+ source = http://gnome.eu.org/gnoduino-0.5.2.tar.gz
+ md5sums = 6caa63fa49bf0ea766fd8d07408cc8af
+
+pkgname = gnoduino
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3f1864bb0ec4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1de0c877aebb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Blackleg blackleg@openaliasbox.org
+# Old Maintainer: speps <speps at aur dot archlinux dot org>
+
+pkgname=gnoduino
+pkgver=0.5.2
+pkgrel=1
+pkgdesc="An implementation of well-known Arduino IDE for GNOME"
+arch=(any)
+url="http://gnome.eu.org/index.php/Gnoduino"
+license=('GPL')
+depends=('avr-libc' 'avrdude' 'avr-binutils' 'avr-gcc' 'pyxdg'
+ 'pygtksourceview2' 'python2-pyserial'
+ 'python2-gconf' 'desktop-file-utils')
+makedepends=('python2-distribute')
+install="$pkgname.install"
+source=("http://gnome.eu.org/$pkgname-$pkgver.tar.gz")
+md5sums=('6caa63fa49bf0ea766fd8d07408cc8af')
+
+prepare() {
+ cd $pkgname-$pkgver
+
+ # do not install gconf schema
+ sed -i "/installSchema.*)$/d" setup.py
+
+ # python2 shebang
+ sed -i "s|bin/python$|&2|" `find . -name "*.py"`
+}
+
+build() {
+ cd $pkgname-$pkgver
+ python2 setup.py build
+}
+
+package() {
+ cd $pkgname-$pkgver
+ python2 setup.py install --root="$pkgdir/"
+
+ # gconf schema
+ install -Dm644 data/$pkgname.schemas \
+ "$pkgdir/usr/share/gconf/schemas/$pkgname.schemas"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/gnoduino.install b/gnoduino.install
new file mode 100644
index 000000000000..fd110bee724b
--- /dev/null
+++ b/gnoduino.install
@@ -0,0 +1,23 @@
+pkgname=gnoduino
+
+post_install() {
+ usr/sbin/gconfpkg --install ${pkgname}
+ post_remove
+}
+
+pre_upgrade() {
+ pre_remove
+}
+
+post_upgrade() {
+ post_install
+}
+
+pre_remove() {
+ usr/sbin/gconfpkg --uninstall ${pkgname}
+}
+
+post_remove() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+}