summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Fontenelle2022-09-19 00:38:29 -0300
committerRafael Fontenelle2022-09-19 00:38:29 -0300
commit47d6197b7a0018c13b5fdf8bb36f0aba4008721c (patch)
tree89089e57175a46416a92567c21a18e992c13c7c9
parent0b741da8982146aaa07ac6b75706d48df282459a (diff)
downloadaur-gnome-browser-connector.tar.gz
Improve python3 path enforcement
Previous patch applied only to python3 finding. However, the version definition also uses python3 binary from PATH. Now the patch enforces all python3 occurrence in meson.build is called using /usr/bin/python3.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a763ce67d8fb..daccc602f16b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gnome-browser-connector
pkgdesc = Native browser connector for integration with extensions.gnome.org
pkgver = 42.1
- pkgrel = 2
+ pkgrel = 3
url = https://wiki.gnome.org/Projects/GnomeShellIntegration
arch = any
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index 766d519e371c..c174bd9df7cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=gnome-browser-connector
pkgver=42.1
-pkgrel=2
+pkgrel=3
pkgdesc='Native browser connector for integration with extensions.gnome.org'
arch=(any)
url="https://wiki.gnome.org/Projects/GnomeShellIntegration"
@@ -25,7 +25,7 @@ pkgver() {
prepare() {
cd $pkgname
# Enforce Arch python package's binary, to avoid different python binary in users' PATH
- sed -i "/find_installation('python3'/s/python3/\/usr\/bin\/python3/" meson.build
+ sed -i "s|'python3'|'/usr/bin/python3'|" meson.build
}
build() {