summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2023-06-28 12:17:53 +0200
committerPellegrino Prevete2023-06-28 12:17:53 +0200
commitb37c696fe93f6d0036b571394d8985ff1c8d1589 (patch)
tree5ddfb768a84fd59b5e3167feb9691131b7774afa
parent5ea15817c328423858514691b7ff13c5f73ba6cf (diff)
downloadaur-gnome-initial-setup-git.tar.gz
update to 44
-rw-r--r--.SRCINFO49
-rw-r--r--PKGBUILD76
2 files changed, 96 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index da3982ec4f86..4fe9500e7bd0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,49 @@
pkgbase = gnome-initial-setup-git
- pkgdesc = Simple, easy, and safe way to prepare a new system
- pkgver = 3.37.92+1+g9feb869
+ pkgdesc = Helps you to set up your OS when you boot for the first time
+ pkgver = 44.0+31+g30e898d9
pkgrel = 1
- url = https://www.gnome.org/
+ url = https://gitlab.gnome.org/GNOME/gnome-initial-setup
arch = x86_64
+ groups = gnome
+ groups = gnome-git
license = GPL
makedepends = git
makedepends = meson
- depends = nm-connection-editor
depends = accountsservice
- depends = cheese
- depends = gnome-desktop
- depends = libgweather
+ depends = cairo
+ depends = fontconfig
+ depends = gcc-libs
+ depends = gdk-pixbuf2
+ depends = gdm
+ depends = geoclue
+ depends = geocode-glib-2
+ depends = glib2
+ depends = glibc
+ depends = gnome-desktop-4
+ depends = gnome-control-center
+ depends = gnome-keyring
depends = gnome-online-accounts
+ depends = gsettings-desktop-schemas
+ depends = gtk3
+ depends = gtk4
+ depends = json-glib
+ depends = krb5
+ depends = libadwaita
depends = libgdm
- depends = libpwquality
- depends = libibus
depends = libgnomekbd
- depends = libpackagekit-glib
- depends = geoclue
- optdepends = gdm: GDM Initial Setup mode
+ depends = libgoa
+ depends = libgweather-4
+ depends = libibus
+ depends = libmalcontent
+ depends = libnma
+ depends = libnma-gtk4
+ depends = libpwquality
+ depends = librest
+ depends = libsecret
+ depends = malcontent
+ depends = pango
+ depends = polkit
+ depends = webkitgtk-6.0
optdepends = gnome-getting-started-docs: GNOME Welcome Tour
provides = gnome-initial-setup
conflicts = gnome-initial-setup
@@ -27,4 +51,3 @@ pkgbase = gnome-initial-setup-git
sha512sums = SKIP
pkgname = gnome-initial-setup-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 0c11acd8e5ef..c3d896c31ec8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,71 @@
-pkgname=gnome-initial-setup-git
+# Maintainer: Pellegrino Prevete (tallero) <pellegrinoprevete@gmail.com>
+
_pkgname=gnome-initial-setup
-pkgver=3.37.92+1+g9feb869
+pkgname="${_pkgname}-git"
+pkgver=44.0+31+g30e898d9
pkgrel=1
-pkgdesc="Simple, easy, and safe way to prepare a new system"
+pkgdesc="Helps you to set up your OS when you boot for the first time"
arch=('x86_64')
-url="https://www.gnome.org/"
+url="https://gitlab.gnome.org/GNOME/${_pkgname}"
license=('GPL')
-depends=('nm-connection-editor' 'accountsservice' 'cheese' 'gnome-desktop' 'libgweather' 'gnome-online-accounts' 'libgdm' 'libpwquality' 'libibus' 'libgnomekbd' 'libpackagekit-glib' 'geoclue')
-makedepends=('git' 'meson')
-optdepends=('gdm: GDM Initial Setup mode' 'gnome-getting-started-docs: GNOME Welcome Tour')
-provides=('gnome-initial-setup')
-conflicts=('gnome-initial-setup')
-source=("git+https://gitlab.gnome.org/GNOME/gnome-initial-setup")
+depends=(
+ accountsservice
+ cairo
+ fontconfig
+ gcc-libs
+ gdk-pixbuf2
+ gdm
+ geoclue
+ geocode-glib-2
+ glib2
+ glibc
+ gnome-desktop-4
+ gnome-control-center
+ gnome-keyring
+ gnome-online-accounts
+ gsettings-desktop-schemas
+ gtk3
+ gtk4
+ json-glib
+ krb5
+ libadwaita
+ libgdm
+ libgnomekbd
+ libgoa
+ libgweather-4
+ libibus
+ libmalcontent
+ libnma
+ libnma-gtk4
+ libpwquality
+ librest
+ libsecret
+ malcontent
+ pango
+ polkit
+ webkitgtk-6.0
+)
+makedepends=(
+ git
+ meson
+)
+optdepends=(
+ 'gnome-getting-started-docs: GNOME Welcome Tour'
+)
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+groups=(gnome gnome-git)
+source=("git+${url}")
sha512sums=('SKIP')
pkgver() {
- cd $_pkgname
+ cd "${_pkgname}"
git describe --tags | sed 's/-/+/g'
}
build() {
- arch-meson $_pkgname build
- ninja -C build
+ arch-meson "${_pkgname}" build
+ meson compile -C build
}
check() {
@@ -29,12 +73,12 @@ check() {
}
package() {
- DESTDIR="$pkgdir" meson install -C build
+ meson install -C build --destdir "${pkgdir}"
install -d -o root -g 102 -m 750 "$pkgdir/usr/share/polkit-1/rules.d"
# Setup system user and group
echo 'u gnome-initial-setup - "GNOME Initial Setup" /run/gnome-initial-setup' |
- install -Dm644 /dev/stdin "$pkgdir/usr/lib/sysusers.d/$_pkgname.conf"
+ install -Dm644 /dev/stdin "$pkgdir/usr/lib/sysusers.d/${_pkgname}.conf"
echo 'd /run/gnome-initial-setup 0700 gnome-initial-setup gnome-initial-setup -' |
- install -Dm644 /dev/stdin "$pkgdir/usr/lib/tmpfiles.d/$_pkgname.conf"
+ install -Dm644 /dev/stdin "$pkgdir/usr/lib/tmpfiles.d/${_pkgname}.conf"
}