summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPlaton Pronko2023-04-10 17:15:34 +0800
committerPlaton Pronko2023-04-10 17:15:34 +0800
commit2f5d6c61c43929501b85adf85046be3c65de6778 (patch)
tree73eb3dcfa3b5dfa8eb8471090a5a113cb54b3693
parent06d0eecf559f4683129d1eb54d7349214f4650c8 (diff)
downloadaur-2f5d6c61c43929501b85adf85046be3c65de6778.tar.gz
add glade-sharp dependency
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
-rw-r--r--remove_glade_dependency.patch33
3 files changed, 6 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f026ed47cf02..1367567e5ba9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gnome-sharp
pkgver = 2.24.4
- pkgrel = 7
+ pkgrel = 8
url = http://gtk-sharp.sourceforge.net
arch = any
license = LGPL
@@ -11,12 +11,10 @@ pkgbase = gnome-sharp
source = 06_fix_mono_path.patch
source = 02_fix_pkg-config_paths.patch
source = 04_initialize_dbus_glib_threading.patch
- source = remove_glade_dependency.patch
md5sums = c3da83bfaa81eb8bac39d7b2232e2604
md5sums = 923434786ec049eed71a68a0825a3d60
md5sums = a8c1bf57a384f5fc20a5890f9f1cef5a
md5sums = 90cd7ea88aaa3011522376153433d115
- md5sums = 3b2fe30de4265a2cba32a5bd0506b6d8
pkgname = gnome-sharp
pkgdesc = GNOME bindings for C#
@@ -53,4 +51,4 @@ pkgname = gconf-sharp-peditors
pkgdesc = Mono bindings for GConf - Property Editing classes
depends = gconf-sharp
depends = libgnome-sharp
-
+ depends = glade-sharp
diff --git a/PKGBUILD b/PKGBUILD
index 582b87d257ed..1bea7191a87a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgvermajor=2
pkgverminor=24
pkgverpatch=4
pkgver=${pkgvermajor}.${pkgverminor}.${pkgverpatch}
-pkgrel=7
+pkgrel=8
arch=(any)
license=(LGPL)
url="http://gtk-sharp.sourceforge.net"
@@ -15,20 +15,17 @@ makedepends=('gtk-sharp-2' 'libgnomeui' 'monodoc')
source=(https://github.com/mono/${pkgbase}/archive/${pkgver}.tar.gz
06_fix_mono_path.patch
02_fix_pkg-config_paths.patch
- 04_initialize_dbus_glib_threading.patch
- remove_glade_dependency.patch)
+ 04_initialize_dbus_glib_threading.patch)
md5sums=('c3da83bfaa81eb8bac39d7b2232e2604'
'923434786ec049eed71a68a0825a3d60'
'a8c1bf57a384f5fc20a5890f9f1cef5a'
- '90cd7ea88aaa3011522376153433d115'
- '3b2fe30de4265a2cba32a5bd0506b6d8')
+ '90cd7ea88aaa3011522376153433d115')
prepare() {
cd "${srcdir}/${pkgbase}-${pkgver}"
patch -Np1 < ../06_fix_mono_path.patch
patch -Np1 < ../04_initialize_dbus_glib_threading.patch
patch -Np1 < ../02_fix_pkg-config_paths.patch
- patch -Np1 < ../remove_glade_dependency.patch
}
build() {
@@ -66,7 +63,7 @@ package_gconf-sharp() {
package_gconf-sharp-peditors() {
pkgdesc="Mono bindings for GConf - Property Editing classes"
- depends=('gconf-sharp' 'libgnome-sharp')
+ depends=('gconf-sharp' 'libgnome-sharp' 'glade-sharp')
cd "${srcdir}/${pkgbase}-${pkgver}"
make -C gconf/GConf.PropertyEditors install DESTDIR="${pkgdir}"
diff --git a/remove_glade_dependency.patch b/remove_glade_dependency.patch
deleted file mode 100644
index b26d83a3245a..000000000000
--- a/remove_glade_dependency.patch
+++ /dev/null
@@ -1,33 +0,0 @@
---- gnome-sharp-2.24.4.orig/configure.in.in 2017-05-10 17:25:41.000000000 +0300
-+++ gnome-sharp-2.24.4/configure.in.in 2020-10-24 10:55:35.458416249 +0300
-@@ -168,10 +168,6 @@
- AC_SUBST(GTKSHARP_CFLAGS)
- AC_SUBST(GTKSHARP_LIBS)
-
--PKG_CHECK_MODULES(GLADESHARP, glade-sharp-2.0 >= $GTK_SHARP_REQUIRED_VERSION)
--AC_SUBST(GLADESHARP_CFLAGS)
--AC_SUBST(GLADESHARP_LIBS)
--
- PKG_CHECK_MODULES(GAPI, gapi-2.0 >= $GTK_SHARP_REQUIRED_VERSION)
- AC_PATH_PROG(GAPI_PARSER, gapi2-parser, no)
- AC_SUBST(GAPI_PARSER)
---- gnome-sharp-2.24.4.orig/sample/Makefile.am 2017-05-10 17:25:41.000000000 +0300
-+++ gnome-sharp-2.24.4/sample/Makefile.am 2020-10-24 10:59:31.879546610 +0300
-@@ -1,4 +1,4 @@
--SUBDIRS = gconf gnomevfs
-+SUBDIRS = gnomevfs
-
- if ENABLE_GNOME
- GNOME_TARGETS=gnome-hello-world.exe canvas-example.exe fifteen.exe
---- gnome-sharp-2.24.4.orig/gconf/GConf.PropertyEditors/Makefile.am 2017-05-10 17:25:41.000000000 +0300
-+++ gnome-sharp-2.24.4/gconf/GConf.PropertyEditors/Makefile.am 2020-10-24 10:54:53.915470149 +0300
-@@ -34,8 +34,7 @@
- PropertyEditorOptionMenu.cs \
- PropertyEditorRadioButton.cs \
- PropertyEditorSpinButton.cs \
-- PropertyEditorToggleButton.cs \
-- EditorShell.cs
-+ PropertyEditorToggleButton.cs
-
- build_sources = $(addprefix $(srcdir)/, $(sources)) $(top_builddir)/AssemblyInfo.cs
-