summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Schendel2020-12-15 22:25:34 +0100
committerChristian Schendel2020-12-15 22:25:34 +0100
commit182bdab7c8b14bfcb6f186fc692f9dd2c9be672e (patch)
treedc905370fea022d508a6f5093a03d80aea81a02f
parent50bb21b3c18667e0b872ff7306fc9f7c1ef97fa2 (diff)
downloadaur-182bdab7c8b14bfcb6f186fc692f9dd2c9be672e.tar.gz
update PKGBUILD to use a commit instead of the release
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD30
2 files changed, 25 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29476f1bd8eb..a57cfd008252 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = gnome-shell-extension-applications-overview-tooltip-git
pkgdesc = Shows a tooltip over applications icons on applications overview
- pkgver = 10
- pkgrel = 1
+ pkgver = v10.r2.g2e81270
+ pkgrel = 2
url = https://github.com/RaphaelRochet/applications-overview-tooltip
+ install = gnome-shell-extension-applications-overview-tooltip.install
arch = any
license = GPL
depends = gnome-shell>=3.38
provides = gnome-shell-extension-applications-overview-tooltip
conflicts = gnome-shell-extension-applications-overview-tooltip
- source = gnome-shell-extension-applications-overview-tooltip-git-10.tar.gz::https://github.com/RaphaelRochet/applications-overview-tooltip/archive/v10.tar.gz
- sha256sums = d3b5646d679025f2e1f60ebf0413dbe0eb5d1f2cd437d45a86375c0002f52dc1
+ source = gnome-shell-extension-applications-overview-tooltip::git+https://github.com/RaphaelRochet/applications-overview-tooltip.git#commit=2e81270c728f421f915900cab2725a8e20c87b0a
+ sha256sums = SKIP
pkgname = gnome-shell-extension-applications-overview-tooltip-git
diff --git a/PKGBUILD b/PKGBUILD
index f3f8c85a99ac..8641e91ca32e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,35 @@
# Maintainer: Christian Schendel <doppelhelix at gmail dot com>
pkgname=gnome-shell-extension-applications-overview-tooltip-git
-pkgver=10
-pkgrel=1
+pkgver=v10.r2.g2e81270
+pkgrel=2
+_commit=2e81270c728f421f915900cab2725a8e20c87b0a
pkgdesc="Shows a tooltip over applications icons on applications overview"
arch=(any)
url="https://github.com/RaphaelRochet/applications-overview-tooltip"
+install=${pkgname%-git}.install
license=('GPL')
depends=('gnome-shell>=3.38')
conflicts=("${pkgname%-git}")
provides=(${pkgname%-git})
-source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('d3b5646d679025f2e1f60ebf0413dbe0eb5d1f2cd437d45a86375c0002f52dc1')
+source=("${pkgname%-git}::git+https://github.com/RaphaelRochet/applications-overview-tooltip.git#commit=$_commit")
+sha256sums=('SKIP')
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ git describe --long --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
package() {
- _reponame="applications-overview-tooltip"
_uuid="applications-overview-tooltip@RaphaelRochet"
-
- cd "${srcdir}/${_reponame}-${pkgver}"
- local dir="${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}"
- mkdir -p "${dir}"
- cp -R * "${dir}"
+ cd "${srcdir}"
+ chmod -R 644 ./*
+ install -d "${pkgdir}/usr/share/gnome-shell/extensions/"
+ mv ${pkgname%-git} ${_uuid}
+ cp -r "${_uuid}" "${pkgdir}/usr/share/gnome-shell/extensions/"
+ #rebuild compiled schemas if missimg
+ if [[ ! -f "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/schemas/gschemas.compiled" ]]; then
+ glib-compile-schemas ${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/schemas
+ fi
+ chmod -R 755 "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/"
}