summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Schendel2022-03-14 11:07:45 +0100
committerChristian Schendel2022-03-14 11:07:45 +0100
commit9fcf90e9365da9a0b41c49e5d59fa981fe45b869 (patch)
tree61fcde70c03b00c73913e33864e36d3bb9c214a4
parentb7e8eedace8cd6f7276bfb545e5e1a0cf4778267 (diff)
downloadaur-9fcf90e9365da9a0b41c49e5d59fa981fe45b869.tar.gz
update
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8c380d584ae7..2182e493c354 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gnome-shell-extension-applications-overview-tooltip-git
pkgdesc = Shows a tooltip over applications icons on applications overview
pkgver = 14.r1.gda94859
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/RaphaelRochet/applications-overview-tooltip
install = gnome-shell-extension-applications-overview-tooltip.install
arch = any
@@ -11,6 +11,7 @@ pkgbase = gnome-shell-extension-applications-overview-tooltip-git
depends = gnome-shell>=3.38
provides = gnome-shell-extension-applications-overview-tooltip
conflicts = gnome-shell-extension-applications-overview-tooltip
+ options = !strip
source = gnome-shell-extension-applications-overview-tooltip::git+https://github.com/RaphaelRochet/applications-overview-tooltip.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 232d10982b44..96d320cbadc2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,20 @@
# Maintainer: Christian Schendel <doppelhelix at gmail dot com>
pkgname=gnome-shell-extension-applications-overview-tooltip-git
pkgver=14.r1.gda94859
-pkgrel=1
+pkgrel=2
pkgdesc="Shows a tooltip over applications icons on applications overview"
arch=(any)
url="https://github.com/RaphaelRochet/applications-overview-tooltip"
install=${pkgname%-git}.install
license=('unknown')
depends=('gnome-shell>=3.38')
-makedepends=('git' 'glib2')
+makedepends=('git'
+ 'glib2')
conflicts=("${pkgname%-git}")
provides=(${pkgname%-git})
source=("${pkgname%-git}::git+${url}.git")
sha256sums=('SKIP')
+options=('!strip')
pkgver() {
cd "$srcdir/${pkgname%-git}"
@@ -29,4 +31,8 @@ package() {
install -Dm 644 {} ${destdir}/{} \;
install -Dm644 "${srcdir}/${pkgname%-git}/schemas/${schema}" \
"${pkgdir}/usr/share/glib-2.0/schemas/${schema}"
+# rebuild compiled GSettings schemas if missing
+ if [[ ! -f "${destdir}/schemas/gschemas.compiled" ]]; then
+ glib-compile-schemas "${destdir}/schemas"
+ fi
}