summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Schendel2021-02-23 10:49:40 +0100
committerChristian Schendel2021-02-23 10:49:40 +0100
commited26bb47a56c9856b8516034d65e3ba6b74753c1 (patch)
tree083ffe1fbf4bdbd78f1337016a4c0dd5fc5e7464
parent10efaa476d80e20b7bf77e7e978c451a69396c36 (diff)
downloadaur-ed26bb47a56c9856b8516034d65e3ba6b74753c1.tar.gz
strip unneeded files
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 71dbf1631dd1..a9d8ba46fe95 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gnome-shell-extension-applications-overview-tooltip-git
pkgdesc = Shows a tooltip over applications icons on applications overview
pkgver = 10.r5.g5758bc7
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/RaphaelRochet/applications-overview-tooltip
install = gnome-shell-extension-applications-overview-tooltip.install
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index b2a882b11f09..110ee5277fe9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Christian Schendel <doppelhelix at gmail dot com>
pkgname=gnome-shell-extension-applications-overview-tooltip-git
pkgver=10.r5.g5758bc7
-pkgrel=1
+pkgrel=2
pkgdesc="Shows a tooltip over applications icons on applications overview"
arch=(any)
url="https://github.com/RaphaelRochet/applications-overview-tooltip"
@@ -23,10 +23,10 @@ package() {
cd "${srcdir}/${pkgname%-git}"
local uuid=$(grep -Po '(?<="uuid": ")[^"]*' metadata.json)
local schema=$(grep -Po '(?<="settings-schema": ")[^"]*' metadata.json).gschema.xml
- local destdir="$pkgdir/usr/share/gnome-shell/extensions/$uuid"
- install -dm755 "$destdir"
+ local destdir="${pkgdir}/usr/share/gnome-shell/extensions/${uuid}"
+ install -dm755 "${destdir}"
+ find . -regextype posix-egrep -regex ".*\.(js|json|xml|css|mo)$" -exec\
+ install -Dm 644 {} ${destdir}/{} \;
install -Dm644 "${srcdir}/${pkgname%-git}/schemas/${schema}" \
"${pkgdir}/usr/share/glib-2.0/schemas/${schema}"
- cp -r * "$destdir"
-
}