summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGreyson Christoforo2022-04-10 12:19:05 +0100
committerGreyson Christoforo2022-04-10 12:19:05 +0100
commit21b82da908df60e05470fce4190edc5961b488da (patch)
tree51d6e0b3ffea421ff0d8976f2963bf87a83d486b
parentbd2e997178960cb84d16803673da52217ebf732a (diff)
downloadaur-21b82da908df60e05470fce4190edc5961b488da.tar.gz
bump version and rewrite PKGBUILD
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD55
3 files changed, 51 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5edf4801f753..49c50b42fb7e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,16 @@
pkgbase = gnome-shell-extension-bing-wallpaper
pkgdesc = Changes your wallpaper daily to the bing.com background image
- pkgver = 36
+ pkgver = 39
pkgrel = 1
- epoch = 2
url = https://github.com/neffo/bing-wallpaper-gnome-extension
arch = any
- license = GPL
- depends = gnome-shell
- source = https://github.com/neffo/bing-wallpaper-gnome-extension/archive/v36.tar.gz
- sha512sums = SKIP
+ license = GPL3
+ makedepends = glib2
+ makedepends = gettext
+ makedepends = intltool
+ makedepends = jq
+ depends = gnome-shell>=40.0
+ source = gnome-shell-extension-bing-wallpaper-39.tar.gz::https://github.com/neffo/bing-wallpaper-gnome-extension/archive/v39.tar.gz
+ sha256sums = 12ce8b5d8fe32468e830914fae810ffb3e25c0172c61f3e3c7d401e2ad2aee60
pkgname = gnome-shell-extension-bing-wallpaper
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..27fd112126d4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+src/
+pkg/
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 45b5f4e255c1..dc93fc9a2f75 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,46 @@
-# Maintainer: gkmcd <g at dramati dot cc>
-# Contributor: dude <brrtsm at gmail dot com>
-
pkgname=gnome-shell-extension-bing-wallpaper
-_pkgname=bing-wallpaper-gnome-extension-
-pkgver=36
+pkgver=39
pkgrel=1
-epoch=2
pkgdesc="Changes your wallpaper daily to the bing.com background image"
-arch=('any')
+arch=(any)
url="https://github.com/neffo/bing-wallpaper-gnome-extension"
-license=('GPL')
-depends=('gnome-shell')
-source=("https://github.com/neffo/bing-wallpaper-gnome-extension/archive/v${pkgver}.tar.gz")
-sha512sums=('SKIP')
+license=(GPL3)
+depends=('gnome-shell>=40.0')
+makedepends=(
+glib2
+gettext
+intltool
+jq
+)
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/neffo/bing-wallpaper-gnome-extension/archive/v${pkgver}.tar.gz")
+sha256sums=('12ce8b5d8fe32468e830914fae810ffb3e25c0172c61f3e3c7d401e2ad2aee60')
+
+build() {
+ cd bing-wallpaper-gnome-extension-${pkgver}
+ glib-compile-schemas schemas/
+ intltool-extract --type=gettext/glade ui/Settings.ui
+ intltool-extract --type=gettext/glade ui/Settings4.ui
+ intltool-extract --type=gettext/glade ui/carousel.ui
+ intltool-extract --type=gettext/glade ui/carousel4.ui
+ xgettext -k -k_ -kN_ --omit-header -o locale/BingWallpaper.pot ui/Settings.ui.h ui/Settings4.ui.h ui/carousel.ui.h ui/carousel4.ui.h extension.js prefs.js blur.js utils.js convenience.js --from-code=UTF-8
+
+ for D in locale/*; do
+ if [ -d "${D}" ]; then
+ msgfmt --template=BingWallpaper.pot --statistics --verbose -o "${D}/LC_MESSAGES/BingWallpaper.mo" "${D}/LC_MESSAGES/BingWallpaper.po" 2>> translations.txt
+ # your processing here
+ fi
+ done
+
+ rm -rf .??*
+ rm -rf BingWallpaper@ineffable-gmail.com.zip screenshot/* screenshot *.sh npm-debug.log icons/original/* *.h package.json *.po *.pot test.js
+}
+
package() {
- _uuid='BingWallpaper@ineffable-gmail.com'
- _install_dir="${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}"
+ cd bing-wallpaper-gnome-extension-${pkgver}
+
+ _uuid="$(cat metadata.json | jq --raw-output '.uuid')"
+ _dest_dir="/usr/share/gnome-shell/extensions/${_uuid}"
- install -dm655 $_install_dir
- cd "${_pkgname}${pkgver}"
- cp -r * $_install_dir
+ mkdir -p "${pkgdir}/${_dest_dir}"
+ cp -r * "${pkgdir}/${_dest_dir}"
}