summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author3x071c2021-09-19 18:56:55 +0200
committer3x071c2021-09-19 18:56:55 +0200
commitd30a96ea68cf10ad592b62eeb18400dc53c8158d (patch)
tree6b0874300127fef9254aacf30d9f37c01651c08d
downloadaur-gnome-shell-extension-dash-to-dock-vinceliuice-git.tar.gz
feat: initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD39
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ee15d5c55933
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = gnome-shell-extension-dash-to-dock-vinceliuice-git
+ pkgdesc = Moves the dash out of the overview transforming it in a dock (vinceliuice fork)
+ pkgver = 54.r562.f3445ac
+ pkgrel = 1
+ url = https://github.com/vinceliuice/dash-to-dock
+ arch = any
+ license = GPL
+ makedepends = intltool
+ makedepends = gettext
+ makedepends = sassc
+ makedepends = git
+ depends = gnome-shell
+ provides = gnome-shell-extension-dash-to-dock
+ provides = gnome-shell-extension-dash-to-dock-vinceliuice
+ conflicts = gnome-shell-extension-dash-to-dock
+ conflicts = gnome-shell-extension-dash-to-dock-vinceliuice
+ source = gnome-shell-extension-dash-to-dock-vinceliuice-git-54.r562.f3445ac::git+https://github.com/vinceliuice/dash-to-dock
+ md5sums = SKIP
+
+pkgname = gnome-shell-extension-dash-to-dock-vinceliuice-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..788cd0c97e24
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: 3x071c <dev ατ 3x071c δοτ com>
+
+_vcs='git'
+_author='vinceliuice'
+_prefix='gnome-shell-extension-'
+_base='dash-to-dock'
+_suffix="-$_author"
+pkgname="$_prefix$_base$_suffix-$_vcs"
+pkgver=54.r562.f3445ac
+pkgrel=1
+pkgdesc="Moves the dash out of the overview transforming it in a dock ($_author fork)"
+arch=('any')
+url="https://github.com/$_author/$_base"
+license=('GPL')
+depends=('gnome-shell')
+makedepends=('intltool' 'gettext' 'sassc' 'git')
+provides=("$_prefix$_base" "${pkgname%-$_vcs}")
+conflicts=("$_prefix$_base" "${pkgname%-$_vcs}")
+_src="$pkgname-$pkgver"
+source=("$_src::$_vcs+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_src"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/^.*-v//;s/-/./g')"
+}
+
+build() {
+ export SASS=sassc
+ cd "$srcdir/$_src"
+ make
+}
+
+package() {
+ cd "$srcdir/$_src"
+ make DESTDIR="$pkgdir/" VERSION="$pkgver" install
+}
+
+# vim: set noet ci pi sts=0 sw=4 ts=4 syntax=bash: