summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCharles Milette2017-06-10 19:38:16 -0400
committerCharles Milette2017-06-10 19:39:02 -0400
commitf3b7a493da65f4b31c7c8d6d8de590e2dd659101 (patch)
tree0921ea6656d0eca421c1b55c7f498432d9fe65f5
downloadaur-gnome-shell-extension-gmail-message-tray-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
-rw-r--r--gschemas.install30
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..77b384c5ec58
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gnome-shell-extension-gmail-message-tray-git
+ pkgdesc = Gmail Message Tray Gnome Shell Extension
+ pkgver = r71.5a5980c
+ pkgrel = 1
+ url = https://github.com/shumingch/GmailMessageTray
+ install = gschemas.install
+ arch = any
+ license = GPL2
+ makedepends = git
+ depends = gnome-shell
+ source = git+https://github.com/shumingch/GmailMessageTray.git
+ md5sums = SKIP
+
+pkgname = gnome-shell-extension-gmail-message-tray-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..25b53fe5dd24
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Charles Milette <charles.milette@gmail.com>
+
+_gitname=GmailMessageTray
+pkgname=gnome-shell-extension-gmail-message-tray-git
+pkgver=r71.5a5980c
+pkgrel=1
+pkgdesc="Gmail Message Tray Gnome Shell Extension"
+arch=('any')
+url="https://github.com/shumingch/$_gitname"
+license=('GPL2')
+depends=('gnome-shell')
+makedepends=('git')
+install='gschemas.install'
+source=("git+https://github.com/shumingch/$_gitname.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${_gitname}/"
+
+ for i in $(find -type f); do
+ install -Dm 644 "$i" "${pkgdir}/usr/share/gnome-shell/extensions/GmailMessageTray@shuming0207.gmail.com/${i}"
+ done
+}
diff --git a/gschemas.install b/gschemas.install
new file mode 100644
index 000000000000..7f4546e45017
--- /dev/null
+++ b/gschemas.install
@@ -0,0 +1,30 @@
+post_install() {
+ /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
+ instructions_install
+}
+
+post_upgrade() {
+ /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
+ instructions_upgrade
+}
+
+post_remove() {
+ /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
+}
+
+instructions_install() {
+ /bin/cat << EOF
+
+Restart GNOME Shell ([Alt]+[F2], r).
+Activate the extension with gnome-tweak-tool.
+
+EOF
+}
+
+instructions_upgrade() {
+ /bin/cat << EOF
+
+Restart GNOME Shell ([Alt]+[F2], r) to load the upgraded extension.
+
+EOF
+}