summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGhassan Alduraibi2023-01-04 01:54:51 +0300
committerGhassan Alduraibi2023-01-04 01:54:51 +0300
commit5f9ae7712f14876af617da58b77808a5e68cada6 (patch)
tree5d4b8512d84da6fb476c2f8531bca9ee34da518e
downloadaur-gnome-shell-extension-hide-keyboard-layout.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD21
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f2df71cae528
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = gnome-shell-extension-hide-keyboard-layout
+ pkgdesc = GNOME Shell extension to hide keyboard layout indicator in status bar.
+ pkgver = 5
+ pkgrel = 1
+ url = https://github.com/ai/hide-keyboard-layout
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = gnome-shell
+ source = gnome-shell-extension-hide-keyboard-layout-5.tar.gz::https://github.com/ai/hide-keyboard-layout/archive/5.tar.gz
+ b2sums = bc87efa5b1264fc66be9409930db353e8c01bf237bb2a44f1cd425ab2e71fe81dd9fd4957f959b5a695f0b45d807cf72ef836fe1f39175a7b8e38a83e0171b88
+
+pkgname = gnome-shell-extension-hide-keyboard-layout
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..69abb76de2b1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Ghassan Alduraibi <git@ghassan.dev>
+
+_name=hide-keyboard-layout
+_uuid=${_name}@sitnik.ru
+pkgname=gnome-shell-extension-${_name}
+pkgver=5
+pkgrel=1
+pkgdesc="GNOME Shell extension to hide keyboard layout indicator in status bar."
+arch=("any")
+url="https://github.com/ai/hide-keyboard-layout"
+license=("MIT")
+depends=("gnome-shell")
+makedepends=("git")
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+b2sums=('bc87efa5b1264fc66be9409930db353e8c01bf237bb2a44f1cd425ab2e71fe81dd9fd4957f959b5a695f0b45d807cf72ef836fe1f39175a7b8e38a83e0171b88')
+
+package() {
+ install -d "$pkgdir/usr/share/gnome-shell/extensions" \
+ && cp -a "$srcdir/${_name}-${pkgver}" "$pkgdir/usr/share/gnome-shell/extensions/${_uuid}"
+}
+