summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2024-04-04 10:29:22 -0600
committerMark Wagie2024-04-04 10:29:22 -0600
commit294c36e4e3e2d74c635cb396447adbc402a72ab1 (patch)
treef4888f9a42c45fe41d5516d39959bcf7d1a4562a
downloadaur-gnome-shell-extension-material-you-colors-git.tar.gz
initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD49
3 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..04478ad8a338
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = gnome-shell-extension-material-you-colors-git
+ pkgdesc = Applies generated libadwaita theme from wallpaper using Material You
+ pkgver = r134.3f6a005
+ pkgrel = 1
+ url = https://github.com/FrancescoCaracciolo/material-you-colors
+ arch = any
+ license = GPL-3.0-or-later
+ makedepends = git
+ makedepends = npm
+ depends = adw-gtk3
+ depends = gnome-shell
+ depends = nodejs
+ optdepends = gdm-tools: GDM theming
+ optdepends = gnome-shell-extensions: GNOME Shell theming via User Themes extension
+ optdepends = python-pywal: Pywal theming
+ provides = gnome-shell-extension-material-you-colors
+ conflicts = gnome-shell-extension-material-you-colors
+ conflicts = gnome-shell-extension-material-you-theme
+ source = git+https://github.com/FrancescoCaracciolo/material-you-colors.git
+ sha256sums = SKIP
+
+pkgname = gnome-shell-extension-material-you-colors-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..112c11a84bfb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
+pkgname=gnome-shell-extension-material-you-colors-git
+_uuid=material-you-colors@francescocaracciolo.github.io
+pkgver=r134.3f6a005
+pkgrel=1
+pkgdesc="Applies generated libadwaita theme from wallpaper using Material You"
+arch=('any')
+url="https://github.com/FrancescoCaracciolo/material-you-colors"
+license=('GPL-3.0-or-later')
+depends=('adw-gtk3' 'gnome-shell' 'nodejs')
+makedepends=('git' 'npm')
+optdepends=('gdm-tools: GDM theming'
+ 'gnome-shell-extensions: GNOME Shell theming via User Themes extension'
+ 'python-pywal: Pywal theming')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}" 'gnome-shell-extension-material-you-theme')
+source=('git+https://github.com/FrancescoCaracciolo/material-you-colors.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd material-you-colors
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd material-you-colors
+
+ # Does not detect system Node.js, NPM, or SassC,
+ # so we'll install in the extension folder like it tries to do anyway
+ export npm_config_cache="$srcdir/npm_cache"
+ npm install --prefix "${_uuid}"
+
+ make
+}
+
+package() {
+ cd material-you-colors
+ install -d "$pkgdir/usr/share/gnome-shell/extensions/${_uuid}"
+ bsdtar xvf "${_uuid}.shell-extension.zip" -C \
+ "$pkgdir/usr/share/gnome-shell/extensions/${_uuid}/" --no-same-owner
+
+ cp -r "${_uuid}/node_modules" "$pkgdir/usr/share/gnome-shell/extensions/${_uuid}"
+
+ mv "$pkgdir/usr/share/gnome-shell/extensions/${_uuid}/locale" "$pkgdir/usr/share/"
+
+ install -Dm644 "${_uuid}/schemas/org.gnome.shell.extensions.material-you-theme.gschema.xml" \
+ "$pkgdir/usr/share/glib-2.0/schemas/org.gnome.shell.extensions.material-you-colors.gschema.xml"
+ rm -rf "$pkgdir/usr/share/gnome-shell/extensions/${_uuid}/schemas/"
+}