summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsaltedcoffii2022-09-27 19:00:53 +0300
committersaltedcoffii2022-09-27 19:00:53 +0300
commiteea955cdef04c6c1f59174e42e07a8fcef881845 (patch)
tree7433ce7b3be3aa7857eeae3188620d88cbeb3409
downloadaur-gnome-shell-extension-notes.tar.gz
Initial Commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD28
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dc92abf34de6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = gnome-shell-extension-notes
+ pkgdesc = A GNOME Shell extension providing customizable sticky notes on the desktop
+ pkgver = 23
+ pkgrel = 1
+ url = https://github.com/maoschanz/notes-extension-gnome
+ arch = any
+ license = GPL-3
+ makedepends = glib2
+ depends = gnome-shell
+ source = gnome-shell-extension-notes-23.tar.gz::https://github.com/maoschanz/notes-extension-gnome/archive/23.tar.gz
+ sha256sums = 92174a83643eb8c256d80ecd58844c0976c159d862aac5cb16d89b295566767b
+
+pkgname = gnome-shell-extension-notes
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..626a409af411
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Cassandra Watergate (saltedcoffii) <cassandrajwatergate@gmail.com>
+
+_pkgname=gnome-shell-extension-notes
+pkgname=$_pkgname
+pkgver=23
+pkgrel=1
+pkgdesc="A GNOME Shell extension providing customizable sticky notes on the desktop"
+arch=('any')
+url="https://github.com/maoschanz/notes-extension-gnome"
+license=('GPL-3')
+depends=('gnome-shell')
+makedepends=('glib2')
+source=($pkgname-$pkgver.tar.gz::https://github.com/maoschanz/notes-extension-gnome/archive/23.tar.gz)
+sha256sums=('92174a83643eb8c256d80ecd58844c0976c159d862aac5cb16d89b295566767b')
+
+_gitsrcdir=notes-extension-gnome
+
+build() {
+ cd $_gitsrcdir-$pkgver
+ ./update-and-compile-translations.sh --all
+ glib-compile-schemas notes@maestroschan.fr/schemas
+}
+
+package() {
+ cd $_gitsrcdir-$pkgver
+ mkdir -p $pkgdir/usr/share/gnome-shell/extensions
+ cp --recursive --no-dereference --preserve=mode,links notes@maestroschan.fr $pkgdir/usr/share/gnome-shell/extensions
+}