summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIgor Dyatlov2021-09-03 19:40:02 +0300
committerIgor Dyatlov2021-09-03 19:40:02 +0300
commit6bcbdce2a01afb3aabc7e9f0d5d5fcbbbaa1525f (patch)
tree69d680604d4e8de003ae50bc4eaab61d4f9d7fe1
parentb13c05057f8b028c7b642c435e73056f40731fe6 (diff)
downloadaur-gnome-shell-extension-screenshotlocations.tar.gz
Updates
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD18
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e2ca7650c280..d6ad5e474af7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
pkgbase = gnome-shell-extension-screenshotlocations
pkgdesc = A GNOME extension for changing the screenshot output directory
pkgver = 8
- pkgrel = 1
+ pkgrel = 2
url = https://codeberg.org/kiyui/gnome-shell-screenshotlocations-extension
arch = any
license = GPL2
makedepends = meson
- makedepends = eslint
depends = gnome-shell
source = https://codeberg.org/kiyui/gnome-shell-screenshotlocations-extension/archive/8.tar.gz
sha256sums = 0a2de2ae960712c4edbf2f303531d828be119a4b9f47ad5292c7f8e15cdeff67
diff --git a/PKGBUILD b/PKGBUILD
index b1fc8b705ca8..9e2d86c6e23e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,27 @@
-# Maintainer: Your Name <youremail@domain.com>
+# Maintainer: Igor Dyatlov <dyatlov.igor@protonmail.com>
pkgname=gnome-shell-extension-screenshotlocations
_pkgname=gnome-shell-screenshotlocations-extension
pkgver=8
-pkgrel=1
+pkgrel=2
pkgdesc="A GNOME extension for changing the screenshot output directory"
arch=('any')
url="https://codeberg.org/kiyui/gnome-shell-screenshotlocations-extension"
license=('GPL2')
depends=('gnome-shell')
-makedepends=('meson' 'eslint')
+makedepends=('meson')
source=(https://codeberg.org/kiyui/gnome-shell-screenshotlocations-extension/archive/8.tar.gz)
sha256sums=('0a2de2ae960712c4edbf2f303531d828be119a4b9f47ad5292c7f8e15cdeff67')
build() {
- cd "$srcdir/${_pkgname}"
- arch-meson --buildtype=plain build
- ninja -C build
+ arch-meson $_pkgname build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
}
package() {
- cd "$srcdir/${_pkgname}"
- DESTDIR="$pkgdir" ninja -C build install
+ DESTDIR="$pkgdir" meson install -C build
}