summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRyan Corder2016-06-08 15:23:23 -0700
committerRyan Corder2016-06-08 15:23:23 -0700
commit143595fd67496659f7a28a65736ae0b73d860217 (patch)
tree06b16ad1f596f3b7dcf0682e3ef233bb35bd6049
downloadaur-gnome-shell-extension-torstatus-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8d2c5364c252
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gnome-shell-extension-torstatus-git
+ pkgdesc = GNOME shell aggregate system menu Tor indicator
+ pkgver = 0.0.5
+ pkgrel = 1
+ url = https://github.com/subgraph/gnome-shell-extension-torstatus
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = gnome-common
+ optdepends = onioncircuits: display Tor circuits and streams
+ source = git://github.com/subgraph/gnome-shell-extension-torstatus.git
+ sha1sums = SKIP
+
+pkgname = gnome-shell-extension-torstatus-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fd051de261f3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Contributor: Ryan Corder <mrc@bofh.io>
+
+pkgname="gnome-shell-extension-torstatus-git"
+pkgver=0.0.5
+pkgrel=1
+pkgdesc="GNOME shell aggregate system menu Tor indicator"
+arch=('i686' 'x86_64')
+url="https://github.com/subgraph/gnome-shell-extension-torstatus"
+license=('GPL')
+source=('git://github.com/subgraph/gnome-shell-extension-torstatus.git')
+sha1sums=('SKIP')
+depends=('gnome-common')
+optdepends=('onioncircuits: display Tor circuits and streams')
+
+build() {
+ cd "$srcdir/gnome-shell-extension-torstatus"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/gnome-shell-extension-torstatus"
+ make DESTDIR="$pkgdir/" install
+}
+
+pkgver() {
+ cd "$srcdir/gnome-shell-extension-torstatus"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}