summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2021-05-22 17:32:22 +0200
committerXZS2021-05-22 17:32:22 +0200
commitb501be29080ecd4b6fb23b53b02d1ca6d321d852 (patch)
tree3230c1aadac0cf85c909852c55bef37c97b3c764
parentd2b2052e90ae96481f7e377690d36c048dd1f190 (diff)
downloadaur-gnome-shell-extension-volume-mixer-git.tar.gz
restore compilation with Pacman 5.2
Since Pacman version 5.2.0 makepkg exits whenever any command in a pkgver function returns a non-zero exit code. A recent correction from the git-makepkg-templates [1] adapts to this, restoring correct processing of the PKGBUILD. As this concern only the build process, not changing any of the resulting package content, the pkgrel is kept constant, to avoid triggering any unnecessary rebuild. [1]: https://github.com/dffischer/git-makepkg-templates/commit/d91fca9b16dd03bc0bf924dbd95dd24b06e232fe
-rw-r--r--PKGBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 016cdbd31993..242eed94fd88 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,7 +24,7 @@ conflicts+=("$_gitname")
pkgver() {
cd ${_gitname:-$pkgname}
git describe --long --tags 2>/dev/null | sed 's/[^[:digit:]]*\(.\+\)-\([[:digit:]]\+\)-g\([[:xdigit:]]\{7\}\)/\1.r\2.g\3/;t;q1'
- [ ${PIPESTATUS[0]} -ne 0 ] && \
+ [ ${PIPESTATUS[0]} -eq 0 ] || \
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {