summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexey Makhmutov2025-04-05 18:47:23 +0300
committerAlexey Makhmutov2025-04-05 18:47:23 +0300
commit13dc66b21dde3adc9a2d5b707a83cb9ba4fdf764 (patch)
tree9a925d0359f633af2e29f9ebc3c73455a6e89cad
parent11d67320a6f9bdcf567453a36cfd2064229187b1 (diff)
downloadaur-gnome-shell-extension-wiggle.tar.gz
Restore support with GNOME 46 and GNOME 47
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--wiggle-gnome48.patch31
3 files changed, 27 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf5a14394978..9425e880a160 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = gnome-shell-extension-wiggle
pkgdesc = Gnome extension that highlights the cursor position when the mouse is moved rapidly.
pkgver = 5
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/mechtifs/wiggle
arch = any
groups = gnome-shell-extensions
license = GPL-2.0-only
- depends = gnome-shell>=1:48
+ depends = gnome-shell>=1:46
options = !strip
options = !debug
source = gnome-shell-extension-wiggle-5.tar.gz::https://github.com/mechtifs/wiggle/archive/refs/tags/5.tar.gz
source = wiggle-gnome48.patch
b2sums = ca12266b5efbea310e4a7cb214791472566ada4e95cbc38baec5cba2ab0467780e3288dcdd1f9c9e71e95aecf8a075c11ade8682eb3cd141c5f452079988ee57
- b2sums = 4b3e456bd7e5c7e6a29f1322d2690572665ae34200834f3e778b7d4746764566b554a1b549b7307b83bdece9abbf3aa797264be2954ac38b7439fb76fa2b8bec
+ b2sums = c8dca9124ccc79da9b22a0d23f27b698eeddd5fef8ba927d288f62030bff02848bf5d8a861407edd0d2803814c58c6d34ed7b866ed983c75a6b45914690e8be5
pkgname = gnome-shell-extension-wiggle
diff --git a/PKGBUILD b/PKGBUILD
index a8316b1a0105..7557f3fdbae3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,24 @@
# Maintainer: Alexey Makhmutov <makhmutov at gmail dot com>
pkgname=gnome-shell-extension-wiggle
pkgver=5
-pkgrel=2
+pkgrel=3
pkgdesc="Gnome extension that highlights the cursor position when the mouse is moved rapidly."
arch=("any")
url="https://github.com/mechtifs/wiggle"
license=("GPL-2.0-only")
groups=("gnome-shell-extensions")
-depends=("gnome-shell>=1:48")
+depends=("gnome-shell>=1:46")
options=("!strip" "!debug")
source=("${pkgname}-${pkgver}.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz"
"wiggle-gnome48.patch")
b2sums=("ca12266b5efbea310e4a7cb214791472566ada4e95cbc38baec5cba2ab0467780e3288dcdd1f9c9e71e95aecf8a075c11ade8682eb3cd141c5f452079988ee57"
- "4b3e456bd7e5c7e6a29f1322d2690572665ae34200834f3e778b7d4746764566b554a1b549b7307b83bdece9abbf3aa797264be2954ac38b7439fb76fa2b8bec")
+ "c8dca9124ccc79da9b22a0d23f27b698eeddd5fef8ba927d288f62030bff02848bf5d8a861407edd0d2803814c58c6d34ed7b866ed983c75a6b45914690e8be5")
_uuid="wiggle@mechtifs"
prepare() {
cd wiggle-$pkgver
- patch -Np2 -i ../wiggle-gnome48.patch
+ patch -Np1 -i ../wiggle-gnome48.patch
}
package() {
diff --git a/wiggle-gnome48.patch b/wiggle-gnome48.patch
index a2f46aa2072b..1c7b56e2ffa8 100644
--- a/wiggle-gnome48.patch
+++ b/wiggle-gnome48.patch
@@ -1,24 +1,33 @@
-diff -ura src/wiggle-5/cursor.js src.new/wiggle-5/cursor.js
---- src/wiggle-5/cursor.js 2024-08-26 19:11:16.000000000 +0300
-+++ src.new/wiggle-5/cursor.js 2025-03-22 23:32:56.247211049 +0300
-@@ -5,7 +5,7 @@
+diff -ura wiggle-5/cursor.js wiggle-5.new/cursor.js
+--- wiggle-5/cursor.js 2024-08-26 19:11:16.000000000 +0300
++++ wiggle-5.new/cursor.js 2025-04-05 18:41:52.395985731 +0300
+@@ -1,11 +1,16 @@
+ 'use strict';
+
+ import Clutter from 'gi://Clutter';
++import * as Config from 'resource:///org/gnome/shell/misc/config.js';
+ import Meta from 'gi://Meta';
export default class Cursor {
constructor() {
- this._tracker = Meta.CursorTracker.get_for_display(global.display);
-+ this._tracker = global.backend.get_cursor_tracker(global.display);
++ if (Config.PACKAGE_VERSION <= 47) {
++ this._tracker = Meta.CursorTracker.get_for_display(global.display);
++ } else {
++ this._tracker = global.backend.get_cursor_tracker(global.display);
++ }
}
get hot() {
-diff -ura src/wiggle-5/metadata.json src.new/wiggle-5/metadata.json
---- src/wiggle-5/metadata.json 2024-08-26 19:11:16.000000000 +0300
-+++ src.new/wiggle-5/metadata.json 2025-03-22 23:34:17.614315511 +0300
-@@ -2,8 +2,7 @@
- "description": "Wiggle is a GNOME Shell extension that magnifies the cursor when the mouse is moved rapidly.",
+diff -ura wiggle-5/metadata.json wiggle-5.new/metadata.json
+--- wiggle-5/metadata.json 2024-08-26 19:11:16.000000000 +0300
++++ wiggle-5.new/metadata.json 2025-04-05 18:43:31.256711177 +0300
+@@ -3,7 +3,8 @@
"name": "Wiggle",
"shell-version": [
-- "46",
+ "46",
- "47"
++ "47",
+ "48"
],
"url": "https://github.com/mechtifs/wiggle",