summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-11-01 13:57:38 +0100
committerXZS2016-11-01 13:57:38 +0100
commit1f636de4385f0ea00f937dc46d1516d758c3808c (patch)
treeb8c87bc0fcbcf34ec7987e1b41bf8fd1c3ef0a20
parent5bef51feebae4bf7ba7c986b89b32d11c2ea4594 (diff)
downloadaur-gnome-shell-extension-wintitle-git.tar.gz
choose newest extension source
Some extensions authors introduce build steps required before installing. Their execution normally produces a completed variant of the extension code in a subdirectory, difficult to tell apart from the original source. The find condition introduced herein proves the process against such cases to come. It always chooses the files created last, ensuring that a build which occurred after mere unpacking will always take precedence.
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9e8af9f63e8b..d41b7ec3baf3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -34,7 +34,8 @@ package() {
}
package_01_locate() {
msg2 'Locating extension...'
- cd "$(find -name 'metadata.json' -execdir test -e extension.js \; -printf %h -quit)"
+ cd "$(find -name 'metadata.json' -execdir test -e extension.js \; \
+ -printf '%C@ %h\n' | sort -nr | sed 's/^.* //;q' )"
extname=$(grep -Po '(?<="uuid": ")[^"]*' metadata.json)
destdir="$pkgdir/usr/share/gnome-shell/extensions/$extname"
}