summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMingi Sung2024-04-01 20:01:42 +0900
committerMingi Sung2024-04-01 20:02:02 +0900
commit256acb680560b7b7ce9876f78e0e89ac5e960a2b (patch)
treeb72f62d28635cfa4223b6827198ff877dbf57ac6
parentb71c9a966a4ae2f44e060a439adf7138be096497 (diff)
downloadaur-256acb680560b7b7ce9876f78e0e89ac5e960a2b.tar.gz
1:46.0-2: Fix `provides`
Signed-off-by: Mingi Sung <dawdleming@gmail.com>
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD6
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0306c4115750..4e4efd6a1a7d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gnome-shell-performance
pkgdesc = Next generation desktop shell | Attempts to improve performances with non-upstreamed merge-requests and frequent stable branch resync
pkgver = 46.0
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = https://wiki.gnome.org/Projects/GnomeShell
arch = x86_64
@@ -35,10 +35,6 @@ pkgbase = gnome-shell-performance
depends = mutter
depends = unzip
depends = upower
- provides = gnome-shell
- provides = gnome-shell=46.0
- provides = gnome-shell=1:46.0
- conflicts = gnome-shell
source = git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=0463511457612ca87f7426b3b01356d1d85bee9b
source = git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git
b2sums = 8684414294c781bd02f89eb76ae04a51a701c51e00966f227989c0a41d161f34e4bfb7e9609f0a902a565aa4ea22f9d9c740d043b668bc132ed6d7471b8d7119
@@ -76,6 +72,10 @@ pkgname = gnome-shell-performance
optdepends = python-gobject: gnome-shell-test-tool performance tester
optdepends = python-simplejson: gnome-shell-test-tool performance tester
optdepends = switcheroo-control: Multi-GPU support
+ provides = gnome-shell
+ provides = gnome-shell=46.0
+ provides = gnome-shell=1:46.0
+ conflicts = gnome-shell
pkgname = gnome-shell-performance-docs
pkgdesc = Next generation desktop shell | Attempts to improve performances with non-upstreamed merge-requests and frequent stable branch resync (API documentation)
diff --git a/PKGBUILD b/PKGBUILD
index 7820b1ca9619..6f92fe7ad9c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -30,7 +30,7 @@ else
pkgname=(gnome-shell-performance gnome-shell-performance-docs)
fi
pkgver=46.0
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc="Next generation desktop shell | Attempts to improve performances with non-upstreamed merge-requests and frequent stable branch resync"
url="https://wiki.gnome.org/Projects/GnomeShell"
@@ -75,8 +75,6 @@ if [ -n "$_enable_check" ]; then
xorg-server-xvfb
)
fi
-provides=(gnome-shell gnome-shell=$pkgver gnome-shell=$epoch:$pkgver)
-conflicts=(gnome-shell)
_commit=0463511457612ca87f7426b3b01356d1d85bee9b # tags/46.0^0
source=(
"git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=$_commit"
@@ -206,6 +204,8 @@ package_gnome-shell-performance() {
'python-simplejson: gnome-shell-test-tool performance tester'
'switcheroo-control: Multi-GPU support'
)
+ provides=(gnome-shell gnome-shell=$pkgver gnome-shell=$epoch:$pkgver)
+ conflicts=(gnome-shell)
groups=(gnome)
meson install -C build --destdir "$pkgdir"