summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMingi Sung2023-04-16 21:30:58 +0900
committerMingi Sung2023-04-16 22:21:53 +0900
commit32467a0e75160ae1452ee1507ea1525259d8b2ed (patch)
tree29f4c93814ea4a123c52ffb5cdb816a956e6071a
parent4dc50d8cfb4aa339f986294eb52449ee9df07e8a (diff)
downloadaur-32467a0e75160ae1452ee1507ea1525259d8b2ed.tar.gz
Allow to spawn realtime threads without the help of rtkit
Signed-off-by: Mingi Sung <fiestalake@disroot.org>
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD3
-rw-r--r--gnome-shell.install8
3 files changed, 12 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb9da7716bd6..5b40852783b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gnome-shell-performance
pkgdesc = Next generation desktop shell | Attempts to improve performances with non-upstreamed merge-requests and frequent stable branch resync
pkgver = 43.4
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = https://wiki.gnome.org/Projects/GnomeShell
arch = x86_64
@@ -51,6 +51,7 @@ pkgbase = gnome-shell-performance
sha256sums = SKIP
pkgname = gnome-shell-performance
+ install = gnome-shell.install
depends = accountsservice
depends = gcr-4
depends = gjs
diff --git a/PKGBUILD b/PKGBUILD
index af3ea7ea9f1e..e9b842cd6f7f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,7 +23,7 @@ _merge_requests_to_use=()
pkgname=gnome-shell-performance
_pkgname=gnome-shell
pkgver=43.4
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc="Next generation desktop shell | Attempts to improve performances with non-upstreamed merge-requests and frequent stable branch resync"
url="https://wiki.gnome.org/Projects/GnomeShell"
@@ -156,5 +156,6 @@ fi
package() {
depends+=(libmutter-11.so)
+ install=gnome-shell.install
meson install -C build --destdir "$pkgdir"
}
diff --git a/gnome-shell.install b/gnome-shell.install
new file mode 100644
index 000000000000..131ab8b0176c
--- /dev/null
+++ b/gnome-shell.install
@@ -0,0 +1,8 @@
+post_install() {
+ setcap cap_sys_nice+ep usr/bin/gnome-shell
+ echo "[Recommendation] Add rt-scheduler to /org/gnome/mutter/experimental-features in dconf setting"
+}
+
+post_upgrade() {
+ post_install()
+}