summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYour Name2019-09-20 12:41:02 +0800
committerYour Name2019-09-20 12:41:02 +0800
commit4a568615c91c06e7b5d1ef578e83fee95ef9ebd8 (patch)
tree53248efa073cf4b4bb12ce721f36398f6105bf9e
parentf48e630490e1f5b4cf3418c78233973fe2040208 (diff)
downloadaur-4a568615c91c.tar.gz
3.34
-rw-r--r--.SRCINFO18
-rw-r--r--110.patch147
-rw-r--r--PKGBUILD97
3 files changed, 22 insertions, 240 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1aa6c9f8f118..915326eb27f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,8 @@
pkgbase = gnome-shell-performance
pkgdesc = Next generation desktop shell | Attempt to improve the performance by non-upstreamed patches
- pkgver = 3.32.2+10+g2483b6038
- pkgrel = 8
+ pkgver = 3.34.0+94+g3d86e6e79
+ pkgrel = 1
+ epoch = 1
url = https://wiki.gnome.org/Projects/GnomeShell
install = gnome-shell-performance.install
arch = x86_64
@@ -9,14 +10,15 @@ pkgbase = gnome-shell-performance
license = GPL2
makedepends = gtk-doc
makedepends = gnome-control-center
- makedepends = evolution-data-server
+ makedepends = evolution-data-server>=3.34
makedepends = gobject-introspection
makedepends = git
makedepends = meson
makedepends = sassc
+ makedepends = asciidoc
depends = accountsservice
depends = gcr
- depends = gjs
+ depends = gjs>=2:1.58
depends = gnome-bluetooth
depends = upower
depends = gnome-session
@@ -32,18 +34,16 @@ pkgbase = gnome-shell-performance
depends = unzip
depends = gstreamer
depends = libibus
- depends = libcap-ng
+ depends = gnome-autoar
optdepends = gnome-control-center: System settings
optdepends = evolution-data-server: Evolution calendar integration
provides = gnome-shell
- provides = gnome-shell=3.32.2+10+g2483b6038
+ provides = gnome-shell=3.34.0+94+g3d86e6e79
conflicts = gnome-shell
- source = gnome-shell-performance::git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=2483b603869009f7294c00e8a5bdb778eb948b6d
+ source = gnome-shell-performance::git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=3d86e6e791a9e59af3248445a2682cbfe20c60b8
source = git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git
- source = 110.patch
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = ea40cd43b370cc767cefeb554d11f7bd3ee30db8f10e74f11731d42cfb7ee44c
pkgname = gnome-shell-performance
diff --git a/110.patch b/110.patch
deleted file mode 100644
index 7d6a415fdb05..000000000000
--- a/110.patch
+++ /dev/null
@@ -1,147 +0,0 @@
-diff --git a/data/theme/gnome-shell-sass/_common.scss b/data/theme/gnome-shell-sass/_common.scss
-index a6357baad..756a39b79 100644
---- a/data/theme/gnome-shell-sass/_common.scss
-+++ b/data/theme/gnome-shell-sass/_common.scss
-@@ -1271,11 +1271,8 @@ StScrollBar {
-
- //search results
-
-- #searchResultsBin {
-- max-width: 1000px;
-- }
--
- #searchResultsContent {
-+ max-width: 1000px;
- padding-left: 20px;
- padding-right: 20px;
- spacing: 16px;
-@@ -1493,7 +1490,6 @@ StScrollBar {
- }
-
- //Some hacks I don't even
-- .search-display > StBoxLayout,
- .all-apps,
- .frequent-apps > StBoxLayout {
- // horizontal padding to make sure scrollbars or dash don't overlap content
-diff --git a/js/ui/iconGrid.js b/js/ui/iconGrid.js
-index 7b128f7f9..9bb8117a0 100644
---- a/js/ui/iconGrid.js
-+++ b/js/ui/iconGrid.js
-@@ -605,6 +605,8 @@ var IconGrid = GObject.registerClass({
- }
-
- _computeLayout(forWidth) {
-+ this.ensure_style();
-+
- let nColumns = 0;
- let usedWidth = this.leftPadding + this.rightPadding;
- let spacing = this._getSpacing();
-diff --git a/js/ui/search.js b/js/ui/search.js
-index fe4f6162b..1bf242215 100644
---- a/js/ui/search.js
-+++ b/js/ui/search.js
-@@ -14,8 +14,8 @@ const SEARCH_PROVIDERS_SCHEMA = 'org.gnome.desktop.search-providers';
- var MAX_LIST_SEARCH_RESULTS_ROWS = 5;
- var MAX_GRID_SEARCH_RESULTS_ROWS = 1;
-
--var MaxWidthBin = GObject.registerClass(
--class MaxWidthBin extends St.Bin {
-+var MaxWidthBox = GObject.registerClass(
-+class MaxWidthBox extends St.BoxLayout {
- vfunc_allocate(box, flags) {
- let themeNode = this.get_theme_node();
- let maxWidth = themeNode.get_max_width();
-@@ -309,7 +309,7 @@ var ListSearchResults = class extends SearchResultsBase {
- }
-
- _createResultDisplay(meta) {
-- return super._createResultDisplay(meta, this._resultsView) ||
-+ return super._createResultDisplay(meta) ||
- new ListSearchResult(this.provider, meta, this._resultsView);
- }
-
-@@ -329,12 +329,6 @@ Signals.addSignalMethods(ListSearchResults.prototype);
- var GridSearchResults = class extends SearchResultsBase {
- constructor(provider, resultsView) {
- super(provider, resultsView);
-- // We need to use the parent container to know how much results we can show.
-- // None of the actors in this class can be used for that, since the main actor
-- // goes hidden when no results are displayed, and then it lost its allocation.
-- // Then on the next use of _getMaxDisplayedResults allocation is 0, en therefore
-- // it doesn't show any result although we have some.
-- this._parentContainer = resultsView.actor;
-
- this._grid = new IconGrid.IconGrid({ rowLimit: MAX_GRID_SEARCH_RESULTS_ROWS,
- xAlign: St.Align.START });
-@@ -345,10 +339,32 @@ var GridSearchResults = class extends SearchResultsBase {
- this._resultDisplayBin.set_child(this._bin);
- }
-
-+ updateSearch(...args) {
-+ if (this._notifyAllocationId)
-+ this.actor.disconnect(this._notifyAllocationId);
-+
-+ // Make sure the maximum number of results calculated by
-+ // _getMaxDisplayedResults() is updated after width changes.
-+ this._notifyAllocationId = this.actor.connect('notify::allocation', () => {
-+ let id = GLib.idle_add(GLib.PRIORITY_DEFAULT, () => {
-+ super.updateSearch(...args);
-+ });
-+ });
-+
-+ super.updateSearch(...args);
-+ }
-+
- _getMaxDisplayedResults() {
-- let parentThemeNode = this._parentContainer.get_theme_node();
-- let availableWidth = parentThemeNode.adjust_for_width(this._parentContainer.width);
-- return this._grid.columnsForWidth(availableWidth) * this._grid.getRowLimit();
-+ let allocation = this.actor.allocation;
-+ let nCols = this._grid.columnsForWidth(allocation.x2 - allocation.x1);
-+ let nResults = nCols * this._grid.getRowLimit();
-+
-+ // If the results is 0 we might not get allocated and the fix in
-+ // updateSearch() won't work.
-+ if (nResults == 0)
-+ return 1;
-+
-+ return nResults;
- }
-
- _clearResultDisplay() {
-@@ -356,7 +372,7 @@ var GridSearchResults = class extends SearchResultsBase {
- }
-
- _createResultDisplay(meta) {
-- return super._createResultDisplay(meta, this._resultsView) ||
-+ return super._createResultDisplay(meta) ||
- new GridSearchResult(this.provider, meta, this._resultsView);
- }
-
-@@ -378,22 +394,16 @@ var SearchResults = class {
- this.actor = new St.BoxLayout({ name: 'searchResults',
- vertical: true });
-
-- this._content = new St.BoxLayout({ name: 'searchResultsContent',
-- vertical: true });
-- this._contentBin = new MaxWidthBin({ name: 'searchResultsBin',
-- x_fill: true,
-- y_fill: true,
-- child: this._content });
--
-- let scrollChild = new St.BoxLayout();
-- scrollChild.add(this._contentBin, { expand: true });
-+ this._content = new MaxWidthBox({ name: 'searchResultsContent',
-+ vertical: true });
-
- this._scrollView = new St.ScrollView({ x_fill: true,
- y_fill: false,
- overlay_scrollbars: true,
- style_class: 'search-display vfade' });
- this._scrollView.set_policy(St.PolicyType.NEVER, St.PolicyType.AUTOMATIC);
-- this._scrollView.add_actor(scrollChild);
-+ this._scrollView.add_actor(this._content);
-+
- let action = new Clutter.PanAction({ interpolate: true });
- action.connect('pan', this._onPan.bind(this));
- this._scrollView.add_action(action);
diff --git a/PKGBUILD b/PKGBUILD
index dff675842076..ab2114505e38 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,34 +4,33 @@
# Contributor: Flamelab <panosfilip@gmail.com
pkgname=gnome-shell-performance
-pkgver=3.32.2+10+g2483b6038
-pkgrel=8
+pkgver=3.34.0+94+g3d86e6e79
+pkgrel=1
+epoch=1
pkgdesc="Next generation desktop shell | Attempt to improve the performance by non-upstreamed patches"
url="https://wiki.gnome.org/Projects/GnomeShell"
arch=(x86_64)
license=(GPL2)
-depends=(accountsservice gcr gjs gnome-bluetooth upower gnome-session gnome-settings-daemon
+depends=(accountsservice gcr 'gjs>=2:1.58' gnome-bluetooth upower gnome-session gnome-settings-daemon
gnome-themes-extra gsettings-desktop-schemas libcanberra-pulse libcroco libgdm libsecret
- mutter-performance nm-connection-editor unzip gstreamer libibus libcap-ng)
-makedepends=(gtk-doc gnome-control-center evolution-data-server gobject-introspection git meson
- sassc)
+ mutter-performance nm-connection-editor unzip gstreamer libibus gnome-autoar)
+makedepends=(gtk-doc gnome-control-center 'evolution-data-server>=3.34' gobject-introspection git meson
+ sassc asciidoc)
optdepends=('gnome-control-center: System settings'
'evolution-data-server: Evolution calendar integration')
groups=(gnome)
provides=(gnome-shell gnome-shell=$pkgver)
conflicts=(gnome-shell)
install="$pkgname.install"
-_commit=2483b603869009f7294c00e8a5bdb778eb948b6d # tags/3.32.2^10
+_commit=3d86e6e791a9e59af3248445a2682cbfe20c60b8 # master
source=("$pkgname::git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=$_commit"
- "git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git"
- "110.patch")
+ "git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git")
sha256sums=('SKIP'
- 'SKIP'
- 'ea40cd43b370cc767cefeb554d11f7bd3ee30db8f10e74f11731d42cfb7ee44c')
+ 'SKIP')
+
pkgver() {
cd $pkgname
-
- git describe --tags | sed "s/-/+/g"
+ git describe --tags | sed 's/-/+/g'
}
prepare() {
@@ -67,77 +66,7 @@ prepare() {
# 3. Fix: Regression/bug fix only available in master (not backported).
# 4. Cleanup: Code styling improvement, function deprecation, rearrangement...
-
-
- # Title: Fixes and performance improvements to the extension system
- # URL: https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/96
- # Type: 1
- # Status: 2
- # Comment:
- git cherry-pick -n 39f10eaa^..6e704ee1
-
- # Title: Refine the app menu a bit
- # URL: https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/406
- # Type: 2
- # Status: 4
- # Comment:
- git cherry-pick -n ffaca005^..56a36165
-
- # Title: iconGrid: Hide children outside allocation loop
- # URL: https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/566
- # Type: 1
- # Status: 4
- # Comment:
- git cherry-pick -n 520cea93
-
- # Title: appDisp allocation cycle fix
- # URL: https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/581
- # Type: 3
- # Status: 4
- # Comment:
- git cherry-pick -n c1c45f95
-
- # Title: iconGrid: Fix animation glitch
- # URL: https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/582
- # Type: 3
- # Status: 4
- # Comment:
- git cherry-pick -n b4797956
-
- # Title: Mild performance improvements on style changes
- # URL: https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/524
- # Type: 1
- # Status: 4
- # Comment: Use only the first commit as the other one causes issues and is reverted
- git cherry-pick -n fb04dafb
-
- # Title: st: Only emit ::style-changed on actual changes
- # URL: https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/505
- # Type: 1
- # Status: 4
- # Comment: Restore this reverted commit to 3.32 as !505 fixes its introduced style glitches
- git cherry-pick -n f74c07b9
-
- # Title: st: Consider non-background properties for ::style-changed
- # URL: https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/595
- # Type: 3
- # Status: 4
- # Comment: Fixes style glitches introduced by !505
- git cherry-pick -n 7359e431^..be40de5a
-
- # Title: Fix the calculation of max number of results in the grid search
- # URL: https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/110
- # Type: 3
- # Status: 4
- # Comment: Makes the grid search icons hidden if using certain custom themes, disabled by default
- # patch -Np1 < ../110.patch
-
- # Title: endSessionDialog: Initialize Polkit permission asynchronously
- # URL: https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/689
- # Type: 1
- # Status: 4
- # Comment:
- git cherry-pick -n 05b345cc -Xtheirs
+ # Empty, because all patches are merged to master as of now
git submodule init
git config --local submodule.subprojects/gvc.url "$srcdir/libgnome-volume-control"